Open File dialog box handles long paths poorly in the Modern theme

VERIFIED DUPLICATE of bug 88010

Status

SeaMonkey
Themes
--
minor
VERIFIED DUPLICATE of bug 88010
17 years ago
10 years ago

People

(Reporter: Ravi, Assigned: Joe Hewitt (gone))

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.1+)
Gecko/20010607
BuildID:    2001061022

The Open File dialog box in the Modern theme displays the full path in a drop
down list that grows with the length of the path. When the path becomes too long
the user interface flows beyond the edge of the dialog box. The box is not
resizable, and the user cannot access the button to move one level higher in the
directory tree or the scroll bar on the file list.

Reproducible: Always
Steps to Reproduce:
1.Apply the Modern theme
2.From the browser choose File->Open File
3.Browse to a long path

Actual Results:  Drop down list with the path grows unbounded, pushing the right
part of the user interface out of the dialog box.

Expected Results:  The path drop down list should stop growing after a certain
point and/or the Open File dialog box should be resizable.

The Classic theme does not have this problem. In it, the drop down list stops
growing and only displays a partial path. I am also unable to reproduce this in
the Windows build, which seems to use a common dialog.

A capture of the Open File dialog while browsing a long path is available at
http://www4.ncsu.edu/~rniyenga/badmozilla.gif
(Assignee)

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 88010 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
vfy
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.