Upgrade jQuery to at least 1.9 or 2.0

RESOLVED FIXED in 52

Status

Socorro
Webapp
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: peterbe, Assigned: adrian)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-])

(Reporter)

Description

5 years ago
We're currently using jquery 1.6.4. which is getting very old.

jQuery 1.9 and 2.0 are significantly faster. jQuery 2.0 also drops support for obscure browsers like IE which also makes it slightly smaller in size.

Also, being on a more modern version of jQuery makes the incremental steps to keep up smaller and easier.
Assignee: nobody → alex.hagerman
Status: NEW → ASSIGNED

Comment 1

5 years ago
Do we have any browser statistics for the crash reports landing? Thanks.
(Reporter)

Comment 2

5 years ago
(In reply to alex.hagerman from comment #1)
> Do we have any browser statistics for the crash reports landing? Thanks.

We don't have this. If you're wondering about minimum browsers to support, don't :)
Feel free to largely ignore that. If it works on latest FF that's good enough for me.

Comment 3

5 years ago
Hi I'm going to have to let this bug go. Had some stuff come up lately that is prohibiting my time from finishing testing, and my VM corrupted that I was working on. Silly me for not making a backup. Sorry.

Updated

5 years ago
Assignee: alex.hagerman → nobody
(Assignee)

Updated

5 years ago
Status: ASSIGNED → NEW
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [mentor=adrian@mozilla.com]
(Assignee)

Updated

5 years ago
Assignee: nobody → adrian
Whiteboard: [mentor=adrian@mozilla.com]

Comment 4

5 years ago
Commits pushed to master at https://github.com/mozilla/socorro-crashstats

https://github.com/mozilla/socorro-crashstats/commit/67afc0d60212f73047de2fa5ccb75c148dc7529b
Fixes bug 853633 - Upgraded jQuery to version 2.0.2 and jQuery UI to version 1.10.3.

https://github.com/mozilla/socorro-crashstats/commit/fc9ef316609077efc0b77a1db1927d20059926cd
Merge pull request #398 from AdrianGaudebert/853633-upgrade-jquery

Fixes bug 853633 - Upgraded jQuery to version 2.0.2 and jQuery UI to ver...

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Target Milestone: --- → 53

Updated

5 years ago
Whiteboard: [qa-]
(Assignee)

Updated

5 years ago
Target Milestone: 53 → 52
You need to log in before you can comment on or make changes to this bug.