Last Comment Bug 853642 - provider menu organization/cleanup
: provider menu organization/cleanup
Status: VERIFIED FIXED
: uiwanted
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: Firefox 22
Assigned To: scaraveo
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-21 14:30 PDT by Shane Caraveo (:mixedpuppy)
Modified: 2013-06-14 13:24 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
turnoff.png (59.18 KB, image/png)
2013-03-21 15:00 PDT, Shane Caraveo (:mixedpuppy)
jboriss: ui‑review+
Details
turnon.png (21.57 KB, image/png)
2013-03-21 15:00 PDT, Shane Caraveo (:mixedpuppy)
no flags Details
move menu (1.34 KB, patch)
2013-03-21 15:02 PDT, Shane Caraveo (:mixedpuppy)
no flags Details | Diff | Splinter Review
bug-empty menu name.png (29.32 KB, image/png)
2013-03-21 15:17 PDT, Shane Caraveo (:mixedpuppy)
no flags Details
move menu, fix missing menu label (3.90 KB, patch)
2013-03-21 15:20 PDT, Shane Caraveo (:mixedpuppy)
markh: review+
Details | Diff | Splinter Review
move menu, fix missing menu label (3.92 KB, patch)
2013-03-22 16:58 PDT, Shane Caraveo (:mixedpuppy)
mixedpuppy: review+
Details | Diff | Splinter Review

Description Shane Caraveo (:mixedpuppy) 2013-03-21 14:30:38 PDT
The provider menu's are currently structured like this:

----
user profile
----
show sidebar
show notifications
----
o provider 1
o provider 2
x provider 3 (current provider)
----
turn on/off current provider
manage services...

From the ux review Boriss and i did, it makes sense to group the provider specific items together, so it would look like:

----
user profile
----
show sidebar
show notifications
turn on/off current provider
----
o provider 1
o provider 2
x provider 3
----
manage services...

Additionally, clicking on the current provider in the list of providers would also turn off the provider, emulating an unchecking of that provider.
Comment 1 Shane Caraveo (:mixedpuppy) 2013-03-21 14:57:44 PDT
(In reply to Shane Caraveo (:mixedpuppy) from comment #0)
> Additionally, clicking on the current provider in the list of providers
> would also turn off the provider, emulating an unchecking of that provider.

via irc we decided against changing that for now.
Comment 2 Shane Caraveo (:mixedpuppy) 2013-03-21 15:00:16 PDT
Created attachment 727910 [details]
turnoff.png
Comment 3 Shane Caraveo (:mixedpuppy) 2013-03-21 15:00:36 PDT
Created attachment 727911 [details]
turnon.png
Comment 4 Shane Caraveo (:mixedpuppy) 2013-03-21 15:02:47 PDT
Created attachment 727913 [details] [diff] [review]
move menu

I almost feel silly asking for review on this.  quick and simple.
Comment 5 Shane Caraveo (:mixedpuppy) 2013-03-21 15:17:29 PDT
Created attachment 727919 [details]
bug-empty menu name.png

since I have to also touch this menu, I'm fixing the bug shown in this menu at the same time.
Comment 6 Shane Caraveo (:mixedpuppy) 2013-03-21 15:20:06 PDT
Created attachment 727922 [details] [diff] [review]
move menu, fix missing menu label
Comment 7 Shane Caraveo (:mixedpuppy) 2013-03-22 13:56:50 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/b65289e2b06c
Comment 8 Matt Brubeck (:mbrubeck) 2013-03-22 16:04:44 PDT
Sorry, I had to back this out because of failures in multiple mochitests:
https://hg.mozilla.org/integration/mozilla-inbound/rev/109739e76662
Comment 9 Shane Caraveo (:mixedpuppy) 2013-03-22 16:58:39 PDT
Created attachment 728515 [details] [diff] [review]
move menu, fix missing menu label

fixed patch, sent to try for a quick verification on one platform.  carrying forward r+

https://tbpl.mozilla.org/?tree=Try&rev=fa5a16b322f7
Comment 10 Shane Caraveo (:mixedpuppy) 2013-03-25 08:33:48 PDT
fixed patch pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/a450ba2ae0a1
Comment 11 Phil Ringnalda (:philor) 2013-03-25 21:48:26 PDT
https://hg.mozilla.org/mozilla-central/rev/a450ba2ae0a1
Comment 12 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-06-14 13:24:01 PDT
Verified fixed in Firefox 22.0b5.

Note You need to log in before you can comment on or make changes to this bug.