Last Comment Bug 853913 - Some MyDashboard "updated" friendly dates are inappropriate and/or broken w.r.t. timezones
: Some MyDashboard "updated" friendly dates are inappropriate and/or broken w.r...
Status: RESOLVED FIXED
:
Product: bugzilla.mozilla.org
Classification: Other
Component: Extensions: MyDashboard (show other bugs)
: Production
: All All
: -- normal (vote)
: ---
Assigned To: David Lawrence [:dkl]
:
Mentors:
: 852994 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-22 10:16 PDT by Gervase Markham [:gerv]
Modified: 2013-12-06 09:16 PST (History)
3 users (show)
See Also:
Due Date:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Gervase Markham [:gerv] 2013-03-22 10:16:53 PDT
MyDashboard is awesome. One problem:

It is currently 5.11pm local time (GMT, UK). One of the bugs listed in my dashboard query is bug 853619, which as I write has a last modification time of:

2013-03-22 02:33 PDT

MyDashboard says it was last updated "tonight".

Firstly, "tonight" is a term generally referring to the night following the current time period, i.e. in the future. "Last night" would refer to the previous period of darkness.

Secondly, that bug was last updated at 9.33am my local time this morning, which from my point of view is not "tonight", "last night" or any night.

So something is a bit wrong here :-)

Gerv
Comment 1 David Lawrence [:dkl] 2013-03-22 14:26:42 PDT
Thought I had this fixed before but wasn't so now I think I have the right combination.

Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bmo/4.2             
modified extensions/MyDashboard/lib/Queries.pm
modified extensions/MyDashboard/lib/TimeAgo.pm
Committed revision 8683.

dkl
Comment 2 David Lawrence [:dkl] 2013-03-22 14:28:17 PDT
*** Bug 852994 has been marked as a duplicate of this bug. ***
Comment 3 Xidorn Quan [:xidorn] (UTC+10) 2013-12-06 04:38:00 PST
When will this fix be actually applied on bugzilla.mozilla.org? It is still broken yet.
Comment 4 Byron Jones ‹:glob› 2013-12-06 09:16:04 PST
(In reply to Xidorn Quan from comment #3)
> When will this fix be actually applied on bugzilla.mozilla.org? It is still
> broken yet.

it was applied in march.  if you're still seeing this issue please file a new bug.

Note You need to log in before you can comment on or make changes to this bug.