permanent PB mode adds "(Private Browsing)" to window title

VERIFIED FIXED in Firefox 21

Status

()

--
minor
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: c.ascheberg, Assigned: c.ascheberg)

Tracking

({regression})

Trunk
Firefox 22
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox20 wontfix, firefox21 verified, firefox22 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
There is a "(Private Browsing)" suffix in the window title if permanent private browsing mode is activated. The suffix should not be shown in that case.
(Assignee)

Comment 1

6 years ago
Created attachment 728709 [details] [diff] [review]
patch

This is a possible patch
Assignee: nobody → c.ascheberg
Attachment #728709 - Flags: review?(ehsan)

Comment 2

6 years ago
Comment on attachment 728709 [details] [diff] [review]
patch

Review of attachment 728709 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, looks good!
Attachment #728709 - Flags: review?(ehsan) → review+
Why we want this behavior? It is now harder to know whether you're in PB mode, isn't it?

Comment 5

6 years ago
(In reply to comment #4)
> Why we want this behavior? It is now harder to know whether you're in PB mode,
> isn't it?

We don't want to keep reminding you that you are in *permanent* PB mode all the time.  We want Firefox in that mode to look similar to regular mode but just don't store any local data about your browsing.  We still set the window title for normal PB mode.
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #5)
> We don't want to keep reminding you that you are in *permanent* PB mode all
> the time.
Why not?

Comment 7

6 years ago
(In reply to comment #6)
> (In reply to :Ehsan Akhgari (needinfo? me!) from comment #5)
> > We don't want to keep reminding you that you are in *permanent* PB mode all
> > the time.
> Why not?

Because it is an explicit choice that you make in the Preferences dialog.  We don't keep reminding you that you have changed other settings there all the time either.
https://hg.mozilla.org/mozilla-central/rev/4e6b20451bb6
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
(Assignee)

Comment 9

6 years ago
Is it worth it to uplift this patch to beta?

Updated

6 years ago
Duplicate of this bug: 859979

Comment 11

6 years ago
Yeah please nominate it for both Aurora and Beta.
(Assignee)

Comment 12

6 years ago
Comment on attachment 728709 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (feature/regressing bug #): bug 799001 / per-window private browsing
User impact if declined: unwanted "(Private Browsing)" suffix in the window title during permanent private browsing mode
Testing completed (on m-c, etc.): m-c, aurora 22.0a2
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #728709 - Flags: approval-mozilla-beta?
(Assignee)

Updated

6 years ago
status-firefox20: --- → affected
status-firefox21: --- → affected
status-firefox22: --- → fixed

Updated

6 years ago
Attachment #728709 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Updated

6 years ago
Keywords: qawanted, verifyme
https://hg.mozilla.org/releases/mozilla-beta/rev/132b6ad632cc
status-firefox20: affected → wontfix
status-firefox21: affected → fixed
Ioana, can you please make sure this gets verified in the latest Aurora build and the upcoming Firefox 21b3 build? Thanks
Keywords: qawanted
QA Contact: ioana.budnar

Comment 15

6 years ago
Verified as fixed on Windows 7 64bit - the 04/10 Aurora and Nightly, and on Ubuntu 12.10 32bit - the 04/11 Aurora and Nightly.

The PB string is no longer displayed in the title bar when passing in permanent PB mode, nor when opening new windows while still in this mode.
Status: RESOLVED → VERIFIED
status-firefox22: fixed → verified

Comment 16

6 years ago
Verified as fixed on Windows 7 64bit, Ubuntu 12.10 32bit and Mac OSX 10.7.5 with Firefox 21 beta 3 (20130416200523).
status-firefox21: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.