Rendering errors with "-moz-linear-gradient" applied to large pages

UNCONFIRMED
Unassigned

Status

()

Core
Layout: Text
UNCONFIRMED
5 years ago
2 years ago

People

(Reporter: Lukas Eder, Unassigned)

Tracking

(Depends on: 1 bug)

19 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 728746 [details]
This Screenshot shows how the error displays on my machine

I am developing a fairly large manual page, which prints out to 150 pages. This page has most of its content contained in a div with a "-moz-linear-gradient" applied. When removing most of the content, this works nicely, but for large pages, lots of rendering errors appear.

Attached is
- an HTML file to reproduce the issue (scroll down a bit)
- a screenshot showing the problem
(Reporter)

Comment 1

5 years ago
Created attachment 728747 [details]
An HTML document to reproduce the issue

Updated

5 years ago
Attachment #728747 - Attachment mime type: text/plain → text/html

Comment 2

5 years ago
Can you reproduce the problem in safe mode?

http://support.mozilla.com/kb/Safe+Mode

Updated

5 years ago
Flags: needinfo?(lukas.eder)
(Reporter)

Comment 3

5 years ago
Yes, the same problem appears in SafeMode
Flags: needinfo?(lukas.eder)

Comment 4

5 years ago
Are you GPU drivers up-to-date?
(Reporter)

Comment 5

5 years ago
I've had this issue on various computers. Right now, I'm using a pretty brand new Windows 8 machine. How can I figure out whether GPU drivers are up-to-date?

Note that I've had several users of my website (http://www.jooq.org) report this issue to me before, independently. I suspect that this is really a Firefox issue. It doesn't happen with other browsers (which use other CSS rules for the same, of course). For now, I've worked around this issue by removing the gradient style for the problematic part.

Comment 6

5 years ago
This is Bug 654570 if HWA was disabled (or blocked).

Updated

5 years ago
Component: General → Layout: Text
Product: Firefox → Core
Depends on: 870524

Comment 7

2 years ago
I can reproduce this problem on my ubuntu
You need to log in before you can comment on or make changes to this bug.