[Gallery] avoid OOM crashes

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
6 years ago
6 months ago

People

(Reporter: djf, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [priority])

(Reporter)

Description

6 years ago
The gallery app tries to defend against OOMs as well as it can, but needs gecko support to do so effectively.  Currently 5 megapixel images that do not have sufficiently large EXIF images cannot really be supported without risking out of memory crashes. Gallery currently is forced to rely on inherently unreliable (and ridiculous) heuristics like arbitrary timeouts to give gecko time to release image memory in an attempt to avoid crashes.  

Gallery currently ignores images > 5 megapixels because it cannot reliably display them without crashes, and it may actually have to reduce this limit. Given that we will soon be running on hardware with cameras that can take > 5mp images, this is a problem.

I'm creating this as a metabug.
(Reporter)

Updated

6 years ago
Depends on: 854784
(Reporter)

Updated

6 years ago
Depends on: 854795
(Reporter)

Updated

6 years ago
Depends on: 854799
(Reporter)

Comment 1

6 years ago
I've added three specific bugs under this meta bug.

Cc'ing Justin because he knows about imagelib. Justin, could you cc appropriate people for this bug?
(Reporter)

Updated

5 years ago
Duplicate of this bug: 858886
Duplicate of this bug: 852061

Updated

5 years ago
Whiteboard: [priority]

Comment 4

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.