Closed Bug 85484 Opened 20 years ago Closed 17 years ago

Proxy: auth prompt doesn't show realm

Categories

(Core :: Networking, defect)

defect
Not set
minor

Tracking

()

RESOLVED FIXED
mozilla1.8beta1

People

(Reporter: bugzilla.mozilla.org-3, Assigned: darin.moz)

References

Details

(Keywords: testcase, Whiteboard: [patch ready to land])

Attachments

(1 file, 2 obsolete files)

When I try to connect to a page using an authenticating proxy server I am
prompted 'Enter username and password for proxy at myproxy.mydomain.tld:5555'.

Expected result:
A prompt saying 'Enter username and password for "My Proxy Realm" at
myproxy.mydomain.tld:5555' (where My Proxy Realm is the actual realm of the
proxy authentication) like it works with regular basic authentication.

I guess this is a minor bug since most people probably use only one password for
their proxy server(s).
marking NEW.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4
Target Milestone: --- → mozilla0.9.3
+qawnated.
I never bothered to look for realms in my Proxy Auth configs or packet traces...
Keywords: qawanted
Summary: Proxy realm not shown in username/password prompt → Proxy: auth prompt doesn't show realm
Target Milestone: mozilla0.9.3 → mozilla0.9.4
Target Milestone: mozilla0.9.4 → mozilla0.9.6
Target Milestone: mozilla0.9.6 → mozilla1.0
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1
+mozilla 1.0

part of a well established RFC.
Keywords: mozilla1.0
Target Milestone: mozilla1.0.1 → Future
moving neeti's futured bugs for triaging.
Assignee: neeti → new-network-bugs
+clean-report.
default owners and target, to put into triage query, per #7.

A comment in bug 60026 said realm does appear, so this might be working already.

My main test proxy seems to use a realm of "unspecified", so I cannot confirm if
this is WFM or not.
Assignee: new-network-bugs → dougt
Target Milestone: Future → ---
-> darin
Assignee: dougt → darin
I logged duplicate bug 210848 on this issue. The proxy authentication challenge
display of the "My Proxy Realm" is still not working as of Mozilla 1.4RC3. I'll
close 210848 and add a vote to this bug.
*** Bug 210848 has been marked as a duplicate of this bug. ***
This is working properly as of Mozilla 1.4 final (Mozilla/5.0 (Windows; U;
Win98; en-US; rv:1.4) Gecko/20030624). It also works with Netscape 7.1.
Marking WFM as per reporter comments.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → WORKSFORME
no, this bug is not fixed.  for proxy auth, the dialog does not show the realm
string.  REOPENING.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
now a testcase
Keywords: testcase
Attached patch Fix (obsolete) — Splinter Review
This patch adds the realm to the proxy dialog.

I am not used to hacking C++ so bear with me if it isn't done right.
Attachment #144409 - Flags: review?(darin)
Comment on attachment 144409 [details] [diff] [review]
Fix

+    const PRUnichar *strings[] = { ToNewUnicode(nsDependentCString(realm)),

this leaks memory... you should nsMemory::Free(strings[0]) after the
FormatStringFromName call
Attachment #144409 - Attachment is obsolete: true
Attachment #144409 - Flags: review?(darin)
Attachment #144413 - Flags: review?(darin)
Attached patch v1.1 patchSplinter Review
revised patch.	better to use NS_ConvertASCIItoUTF16 instead of ToNewUnicode. 
that way you avoid a heap allocation in most cases.
Attachment #144413 - Attachment is obsolete: true
Attachment #144413 - Flags: review?(darin) → review-
Attachment #145123 - Flags: superreview?(bzbarsky)
Attachment #145123 - Flags: review?(cbiesinger)
-> 1.8 alpha since we're already into the localization freeze for 1.7 final.
Status: REOPENED → ASSIGNED
OS: Windows 2000 → All
Priority: P4 → --
Hardware: PC → All
Whiteboard: [patch]
Target Milestone: --- → mozilla1.8alpha
Attachment #145123 - Flags: review?(cbiesinger) → review+
Comment on attachment 145123 [details] [diff] [review]
v1.1 patch

sr=bzbarsky
Attachment #145123 - Flags: superreview?(bzbarsky) → superreview+
CONFIRIMED:
Testcase available @ mozilla office.
contact me for the config info.

Proxy-authenticate: basic realm="is this a realm"

For anyone using Netscape Proxy Server, the configuation is under:
Restrict Access -> Deny -> "Login Prompt"

Also, while I'm here, I noticed that the proxy auth dialog does not display the
port number. Should I file a separate bug?
Whiteboard: [patch] → [patch ready to land]
Target Milestone: mozilla1.8alpha1 → mozilla1.8beta
fixed-on-trunk for 1.8beta

> Also, while I'm here, I noticed that the proxy auth dialog does not display the
> port number. Should I file a separate bug?

I modified the patch to fix this problem.  Thanks for pointing it out.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.