Closed Bug 855041 Opened 8 years ago Closed 8 years ago

Add mozprofile 0.6 and ManifestDestiny 0.5.6 to puppetagain

Categories

(Release Engineering :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ahal, Unassigned)

References

Details

(Whiteboard: [mozbase])

Sorry, have a request for puppetagain again. This is needed for bug 835930. Aki, how hard would it be to set something up that mirrors the mozbase packages from pypi to puppetagain anytime they get updated? I guess it would be hard to make sure that nothing automatically starts using the new packages.

Anyway, mozprofile 0.6 and ManifestDestiny 0.5.4 are both already on pypi. Thanks a bunch!
Whiteboard: [mozbase]
Yeah. I'm not sure polling pypi would be difficult, but we've shown that we don't have good python package version control.  An automated update would most likely make random things break without a blame trail.
(In reply to Aki Sasaki [:aki] from comment #1)
> Yeah. I'm not sure polling pypi would be difficult, but we've shown that we
> don't have good python package version control.  An automated update would
> most likely make random things break without a blame trail.

Is this worth discussion?  I'm not sure what is meant here or what is desired exactly.  For mozbase, we have a fairly precise versioning policy (which of course does not necessarily imply good).
I see ManifestDestiny 0.5.6; which do you want?
(In reply to Jeff Hammel [:jhammel] from comment #2)
> (In reply to Aki Sasaki [:aki] from comment #1)
> > Yeah. I'm not sure polling pypi would be difficult, but we've shown that we
> > don't have good python package version control.  An automated update would
> > most likely make random things break without a blame trail.
> 
> Is this worth discussion?  I'm not sure what is meant here or what is
> desired exactly.  For mozbase, we have a fairly precise versioning policy
> (which of course does not necessarily imply good).

Yes.
The issue is we're taking either any version or any version >= some_version.  Which means any update to that package on puppetagain will change what version of that package tests use.

If we specified a version everywhere, via an in-tree requirements.txt or whatever, then we would have an in-tree place to view when we changed those requirements.
(In reply to Aki Sasaki [:aki] from comment #3)
> I see ManifestDestiny 0.5.6; which do you want?

Ah, lets do 0.5.6 then. The mozprofile setup.py is ManifestDestiny >= 0.5.4.
Summary: Add mozprofile 0.6 and ManifestDestiny 0.5.4 to puppetagain → Add mozprofile 0.6 and ManifestDestiny 0.5.6 to puppetagain
Pushed. That should propagate within 30 minutes.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.