Closed Bug 855230 Opened 7 years ago Closed 6 years ago

Don't use CaptionText colour for luna-blue in fullscreen (-moz-dialog background)

Categories

(Firefox :: Theme, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 28

People

(Reporter: MattN, Assigned: MattN)

References

Details

(Whiteboard: [good first verify])

Attachments

(1 file, 1 obsolete file)

The titlebar colour isn't shown on the tabs toolbar in fullscreen mode so tab text using CaptionColor is unreadable.

STR:
1) Switch to luna blue XP theme
2) Maximize the window
3) Enter fullscreen with F11

Make sure tab text is readable.

Either one of you can review this simple patch.
Attachment #730055 - Flags: review?(mconley)
Attachment #730055 - Flags: review?(dao)
Comment on attachment 730055 [details] [diff] [review]
v.1 Simple patch to add :not([inFullscreen]) to selector

> %ifndef WINDOWS_AERO
> /* Use lighter colors of buttons and text in the titlebar on luna-blue */
> @media (-moz-windows-theme: luna-blue) {
>-  #main-window[tabsintitlebar] .tabbrowser-tab:not([selected]):not(:-moz-lwtheme) {
>+  #main-window[tabsintitlebar]:not([inFullscreen]) .tabbrowser-tab:not([selected]):not(:-moz-lwtheme) {
>     color: CaptionText;
>   }

As mentioned in bug 738491 comment 152, this shouldn't be luna-blue-specific.

>   #main-window[tabsintitlebar] .tabbrowser-arrowscrollbox > .scrollbutton-up,
>   #main-window[tabsintitlebar] .tabbrowser-arrowscrollbox > .scrollbutton-down {
>     list-style-image: url(chrome://browser/skin/tabbrowser/tab-arrow-left-inverted.png);
>   }

This needs an update as well.
Attachment #730055 - Flags: review?(dao) → review-
(In reply to Dão Gottwald [:dao] from comment #1)
> >     color: CaptionText;
> 
> As mentioned in bug 738491 comment 152, this shouldn't be luna-blue-specific.

Ah, I didn't fully understand what was being asked there and forgot to clarify.

> This needs an update as well.

Sorry, I should have realized the other luna-blue styles needed updating.
Attachment #730055 - Attachment is obsolete: true
Attachment #730055 - Flags: review?(mconley)
Attachment #730586 - Flags: review?(dao)
Attachment #730586 - Flags: review?(dao) → review+
Whiteboard: [fixed-in-ux]
Duplicate of this bug: 852987
https://hg.mozilla.org/mozilla-central/rev/8313c2f94b91
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-ux]
Target Milestone: --- → Firefox 28
Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.