Closed Bug 855971 Opened 7 years ago Closed 7 years ago

Switch HTMLDocument to WebIDL bindings

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla23

People

(Reporter: bzbarsky, Assigned: peterv)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-needed, site-compat)

Attachments

(1 file, 1 obsolete file)

The bug we used to have on this got repurposed.
Blocks: 855972
Attached patch v1 (obsolete) — Splinter Review
Assignee: nobody → peterv
Status: NEW → ASSIGNED
Attached patch v2Splinter Review
Attachment #731080 - Attachment is obsolete: true
Attachment #743209 - Flags: review?(bzbarsky)
Comment on attachment 743209 [details] [diff] [review]
v2

>+    is(globalScope.querySelectorAll(".variables-view-variable:not([non-match])").length, 1,
>       "There should be 2 variables displayed in the global scope");

Fix the test message?

>+    is(innerScope.querySelectorAll(".variables-view-property:not([non-match])").length, 7,
>       "There should be 8 properties displayed in the inner scope");

And here.  Do we understand why these were needed?

r=me with that.
Attachment #743209 - Flags: review?(bzbarsky) → review+
Looks like the debugger tests no longer need some of the changes from this bug (the [object Proxy] bit because jimb fixed that bustage, and not sure about the rest).

I took out those parts of the patch, verified that the tests that failed when this was pushed now pass for me locally, and pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/adaaf6641785
https://hg.mozilla.org/mozilla-central/rev/adaaf6641785
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Depends on: 869195
No longer depends on: 841447
Depends on: 869825
Depends on: 870423
Depends on: 874321
Duplicate of this bug: 877491
Duplicate of this bug: 877491
Depends on: 903332
Depends on: 910220
Duplicate of this bug: 718420
Depends on: 905493
Depends on: 1297304
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.