Closed Bug 718420 Opened 9 years ago Closed 7 years ago

Firefox don't remove id/name mappings from document object when the id has been removed

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 855971

People

(Reporter: emk, Unassigned)

References

Details

Attachments

(2 files)

Attached file Test
Steps to reproduce:
1. Open the attached test case.

Actual result:
Firefox: 42 [object HTMLImageElement] [object HTMLImageElement] 
Chrome/IE9: 42 42 42
Opera: 42 [object HTMLImageElement] 42

Expected result:
I believe Opera is right here per the current spec (correct me if I'm wrong).
This is basically the same as bug 307415.  New DOM bindings might fix this...
Depends on: 307415
Attached file Another test
Firefox: 42 [object HTMLImageElement] [object HTMLImageElement]
IE8: 42 42 42
Chrome: 42 undefined undefined
Opera: 42 42 42

What is the right behavior in this case? If I understand correctly, "42 [object HTMLImageElement] 42" is right because supported property names with [OverrideBuiltin] will have a priority to own properties (again, correct me if I'm wrong).
Text attachment 588865 [details]:
Nightly26.0.a1: 42 [object HTMLImageElement] 42 
Aurora25.0a2  : 42 [object HTMLImageElement] 42 
Firefox24.0b8 : 42 [object HTMLImageElement] 42
Firefox23.0.1 : 42 [object HTMLImageElement] 42 
Firefox22.0   : 42 [object HTMLImageElement] [object HTMLImageElement] 
Firefox17.0.8esr : 42 [object HTMLImageElement] [object HTMLImageElement] 

It seemed to be fixed in Firefox23.0.

Fixed window(m-i)
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/e500bc167b4e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130504 Firefox/23.0 ID:20130504170147
Fixed:
http://hg.mozilla.org/integration/mozilla-inbound/rev/1a60a6e9d9b8
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130504 Firefox/23.0 ID:20130504184447
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e500bc167b4e&tochange=1a60a6e9d9b8

I guess this is fixed by Bug 855971


Another test attachment 589083 [details]:
Nightly26.0.a1: 42 42 42 
Aurora25.0a2  : 42 42 42
Firefox24.0b8 : 42 42 42 
Firefox23.0.1 : 42 42 42
Firefox22.0   : 42 [object HTMLImageElement] [object HTMLImageElement] 
Firefox17.0.8esr : 42 [object HTMLImageElement] [object HTMLImageElement]
Indeed. Thank you, Alice!
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 855971
Flags: in-testsuite?
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.