Status

()

Core
Networking
RESOLVED DUPLICATE of bug 855620
5 years ago
5 years ago

People

(Reporter: gia, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
/home/gia/mozilla-central/netwerk/sctp/src/user_socket.c: In function ‘usrsctp_dumppacket’:
/home/gia/mozilla-central/netwerk/sctp/src/user_socket.c:3123:11: warning: format ‘%d’ expects argument of type ‘int’, but argument 8 has type ‘__suseconds_t’ [-Wformat]
/home/gia/mozilla-central/netwerk/sctp/src/user_socket.c:3123:11: warning: format ‘%d’ expects argument of type ‘int’, but argument 8 has type ‘__suseconds_t’ [-Wformat]
(Reporter)

Comment 1

5 years ago
i want to start contributing to Firefox. I will submit the patch soon.
(Reporter)

Comment 2

5 years ago
Created attachment 731632 [details] [diff] [review]
patch v1
Attachment #731632 - Flags: review?(bsmith)
Attachment #731632 - Flags: review?(bsmith) → review?(rjesup)

Updated

5 years ago
Attachment #731632 - Flags: review?(rjesup) → review+
Blocks: 819664
(Reporter)

Updated

5 years ago
Keywords: checkin-needed
This is actually a (minor) bug in the upstream library used here (usrsctp).

Comment 4

5 years ago
This was actually fixed upstream in
http://code.google.com/p/sctp-refimpl/source/detail?r=8412
on February 10th.
This will then be fixed by the upstream update about to land.  Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → DUPLICATE
Duplicate of bug: 855620
You need to log in before you can comment on or make changes to this bug.