paste into TO: line ignores email addresses after a CR in compose window

RESOLVED FIXED in seamonkey2.1final

Status

SeaMonkey
MailNews: Composition
--
major
RESOLVED FIXED
17 years ago
7 years ago

People

(Reporter: emmet, Assigned: ewong)

Tracking

({dataloss, polish})

Trunk
seamonkey2.1final
dataloss, polish
Bug Flags:
blocking-seamonkey1.0a -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug])

Attachments

(1 attachment)

1.36 KB, patch
Karsten Düsterloh
: review+
Karsten Düsterloh
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.1+)
Gecko/20010608
BuildID:    2001060820

If I have a 'notepad' file containing this text (no spam please!)

stevecr@cogs.sussex.ac.uk,
faith@runtime-collective.com,
zecabrandao@hotmail.com,
eliot@cogs.sussex.ac.uk

and I (in windows!) Copy it to the clipboard and then call
up a new messge in Mozilla and click on the 'To:' line to
paste the addresses in I find that *only the first one*
is inserted and everything after the CR on the first line
is just ignored.

*Variant bug*

If I then chain all the email addresses together like

stevecr@cogs.sussex.ac.uk,faith@runtime-collective.com,zecabrandao@hotmail.com,eliot@cogs.sussex.ac.uk

and insert them into the 'To:' box they are inserted *as is*
rather than parsed as seperate addresses and inserted
into four 'To:' boxes.



Reproducible: Always
Steps to Reproduce:

Comment 1

17 years ago
Confirmed
Platform: PC
OS: Windows 98
Mozilla Build: 2001072003

Marking NEW.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish, ui

Comment 2

16 years ago
*** Bug 138461 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
This needs keyword 4xp added.  Every other email program I have ever used,
including Netscape Messenger, had this functionality.  It still exists as of
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0rc1) Gecko/20020417.

Updated

16 years ago
Keywords: 4xp, dataloss

Comment 4

16 years ago
*** Bug 112781 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
This bug needs some more attention.  While it seems minor, as more people begin
to explore using Moz or NS for email again, this deficiency will be a major
problem for some.

We're having a LOT of trouble with Eudora as we move to 100% SSL IMAP and we
have a lot of Eudora users.  We've begun to convince many that the Mozilla
Mail/News client is just as good, faster, less likely to corrupt boxes, etc. 
They really like it, but almost ALL of the converted users bemoan the lack of an
easy way to paste in a list of email addresses and its always 'Well Eudora did
it, Outlook does, even NS 4" etc

I also belive this bug's scope need to be widened a bit.  In addition to the
Compose window To: fields, you shoudl be able to paste a list of email addresses
into the New Mailing List window of the address book.  I mean, nobody is going
to type in each individual address for a mailing list greater than 5 people or
so.  Cut and paste!

Beyond that, Netscape 4 even allowed you to drag and drop a selection of email
addresses onto teh Compose To: fields or the New Mailing list window.

This may seem like a minor bug, but you'd be surprised by the number of normal
client users who find this to be a showstopper or serious deficiency.

I know this isn't 'helpful' and I wish I was better versed in Mozilla coding,
but I just wanted to add some insight into the lack of a very common
functionality in most peer applications
Occurs at least on windows and linux: all/all

I would also suggest to raise severity to normal or major since
practically every current email program does have this.
OS: Windows 2000 → All
Hardware: PC → All

Updated

16 years ago
Blocks: 92997
The same problem exists when trying to paste into a mailing list window.
There is also no way to import into a mailing list, so it is extremely
difficult to do this or work around it.
Important for many corporate users.

Severity: minor → normal

Comment 8

16 years ago
By the definitions on <http://bugzilla.mozilla.org/bug_status.html#severity> and
<http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>, crashing and dataloss
bugs are of critical or possibly higher severity.  Only changing open bugs to
minimize unnecessary spam.  Keywords to trigger this would be crash, topcrash,
topcrash+, zt4newcrash, dataloss.
Severity: normal → critical

Comment 9

15 years ago
*** Bug 189578 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
*** Bug 206007 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
*** Bug 166555 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 12

15 years ago
Bug 227206 may have fixed this bug however testing pending fixing 229203

Comment 13

15 years ago
taking. I have actually fixed this for thunderbird and it partially works for
Seamonkey. 

Seamonkey & thunderbird can now accept a comma delimited list of names all one
one line (typed in or pasted in from a document/spreadsheet/notepad/etc.) and
after you hit enter we will auto complete each name individually.

Thunderbird can also accept a selection of addresses from Excel where the names
are delimited by line returns (or cells) such as: 
Scott
David
Paul

See Bug #229203 about why this won't work in the suite yet.

I'm going to mark this fixed. The remaining seamonkey issue can be tracked in
229203.
Assignee: sspitzer → mscott

Updated

15 years ago
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 14

15 years ago
This bug is not fixed on linux (fedora 1 core) with Thunderbird 0.5.  If I use
vim to put write three email addresses, each on its own line, then copy and
paste the addresses into the "to" bar in t/b, only the last one is displayed. 
However, you can use the up and down arrows to display the others - the single
line "to" bar actually scrolls up and down.  Tabbing out of the line, pressing
enter or sending the message does nothing to expand the email addresses out onto
their own lines.  This is almost certainly due to linux's lf endings instead of
crlf.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 15

15 years ago
Here's the patch for the line issue:

http://bugzilla.mozilla.org/attachment.cgi?id=137854&action=view

I'm testing for CRLF which I'm guessing won't fly on linux :)

Comment 16

14 years ago
This functionality is really important for Seamonkey. Comma-separated is an 
improvement, but users expect to be able to paste a multi-line list (CRLF, not 
just commas) into the recipient listbox and the mailing list listbox (both 
addressingWidgets). Could anyone up this bug's priority?

Comment 17

14 years ago
Is it considered too risky to put that CRLF patch in the code?
We really want to have this...
People keep lists of mail addresses in programs like Excel, copy a column out of
that, and want to send mail to these addresses.
Using Office and Outlook it is also possible (and better) to do this using form
letters, but that won't work with Mozilla because the MAPI32.DLL emulation is
not yet good enough.
I would really like to be able to suggest the alternative of pasting the
addresses, but I think it is difficult for the average Windows user to quickly
transform a CRLF-separated list into a comma-separated list...
Product: Browser → Seamonkey

Updated

13 years ago
Flags: blocking-seamonkey1.0a?
Severity: critical → normal
Flags: blocking-seamonkey1.0a? → blocking-seamonkey1.0a-

Comment 18

13 years ago
This bug appears to have been fixed, at least for Thunderbird 1.0.2 under
Windows XP Professional (SP2):  I create a list of e-mail addresses in Notepad,
say, one per line.  I copy the entire document and paste into a To: field in
Thunderbird.  Initially, the entire list appears on the one line there with
commas separating the addresses.  But if I just press Enter, then the addresses
are automatically distributed one per line.
(In reply to comment #18)
> This bug appears to have been fixed, at least for Thunderbird 1.0.2 under
> Windows XP Professional (SP2):  I create a list of e-mail addresses in Notepad,
> say, one per line.  I copy the entire document and paste into a To: field in
> Thunderbird.  Initially, the entire list appears on the one line there with
> commas separating the addresses.  But if I just press Enter, then the addresses
> are automatically distributed one per line.

The same happens in suite.  That's far from ideal though.

Comment 20

13 years ago
I'd say that the best thing to solve this issue here is a combination of Scott's
approach in bug 229203, combined with Jesse's comment there:
- Implement a textbox string attribute "linebreakreplace" that takes a string
all linebreaks pasted into that textbox should be replaced by
- Set this attribute to "," for all addressing widget textboxes

Comment 21

13 years ago
(In reply to comment #19)
> (In reply to comment #18)
> > This bug appears to have been fixed, at least for Thunderbird 1.0.2 under
> > Windows XP Professional (SP2):  I create a list of e-mail addresses in Notepad,
> > say, one per line.  I copy the entire document and paste into a To: field in
> > Thunderbird.  Initially, the entire list appears on the one line there with
> > commas separating the addresses.  But if I just press Enter, then the addresses
> > are automatically distributed one per line.
> 
> The same happens in suite.  That's far from ideal though.


I just tried this in v 1.7.8 and it doesn't work.  I guess I need to set up 1.8
and try that.

Comment 22

13 years ago
As some of our users need this, and there does not seem to be a Mozilla 1.8
forthcoming (what a pity...), I have written a small cgi-bin program on our
Intranet that puts up a big text field, where users can paste their addresses
from notepad or copied from their Excel column, POST the form, and it returns
with all the addresses comma-separated on a single line.
They then cut that and paste it in the To: field, which is then expanded to
individual lines when ENTER is pressed.

It is cumbersome, but at least it works.
Unfortunately this is not the only bug in 1.7.8 that is fixed in the trunk
version, but that will never be fixed for us because the powers that be have
decided that this trunk version will never be released as 1.8 :-(

Comment 23

12 years ago
seems pretty lame
URL: n/a
Severity: normal → major
Summary: copy & paste into TO: line ignores addresses after a CR → copy & paste into TO: line ignores email addresses after a CR in compose window

Comment 24

12 years ago
Any idea when this will be fixed in Seamonkey?

Comment 25

12 years ago
the key is Bug 229203 comment 3 "seamonkey has other single line text box widgets which won't want this behavior" in nsTextEditRules.


Max comment #14
> not fixed on linux Thunderbird ... due to linux's lf endings instead of crlf.
comment #15
> [in] http://bugzilla.mozilla.org/attachment.cgi?id=137854&action=view
> I'm testing for CRLF which I'm guessing won't fly on linux :)

note the final patch for bug 229203 didn't fix linux (thunderbird), bug is marked windows only and is closed.  I don't see one opened for linux. You might open one for linux.


for some history see also bug 227206.
with TB already fixed, seems like this might be an OK firstbug.
dataloss => critical?
Assignee: mscott → mail
Status: REOPENED → NEW
QA Contact: esther
Summary: copy & paste into TO: line ignores email addresses after a CR in compose window → paste into TO: line ignores email addresses after a CR in compose window
Whiteboard: [good first bug]

Comment 26

12 years ago
(In reply to comment #19)
> (In reply to comment #18)
> > This bug appears to have been fixed, at least for Thunderbird 1.0.2 under
> > Windows XP Professional (SP2):  I create a list of e-mail addresses in Notepad,
> > say, one per line.  I copy the entire document and paste into a To: field in
> > Thunderbird.  Initially, the entire list appears on the one line there with
> > commas separating the addresses.  But if I just press Enter, then the addresses
> > are automatically distributed one per line.
> 
> The same happens in suite.  That's far from ideal though.

Works this way in T-Bird 1.5.0.5 on linux.  That behavior is acceptable AFAIC.

Updated

12 years ago
Blocks: 360488

Comment 27

12 years ago
Still not working on Seamonkey after 5 years.

Comment 28

11 years ago
(In reply to comment #27)
> Still not working on Seamonkey after 5 years.
> 
It's working for me, at least the conversion of newlines to commas. See bug 229203. Set the preference "editor.singleLine.pasteNewlines" to the value "4". I'm using SM 1.5a.

Comment 29

11 years ago
This is WFM under Linux, because editor.singleLine.pasteNewlines is 0 (paste newlines intact) here. The default for everyone else is 1 (paste up to the first newline), Thunderbird uses 4 (replace with commas).

We surely can't take TB's value, since this would break pasting in all our singleline textboxes (thus removing dependency).

Actually, I think that the paste behaviour should be handled by an attribute of the textbox/textarea, not by a global pref.
(This might mean fixing <http://mxr.mozilla.org/seamonkey/source/editor/libeditor/text/nsPlaintextEditor.cpp#129> etc.)
No longer blocks: 360488

Comment 30

9 years ago
The WFM under Linux is questionable.  With editor.singleLine.pasteNewlines = 0 users see only the last one of the three addresses pasted into the address area.  The solution for addressingWidget.js from bug 227206 does not fire just after pasting.  The addresses are only separated after a keystroke or after clicking Send Message or Edit Draft.

In general SM should replace Newlines with a Whitespace character.  I filed bug 533285 for this.

In the address area Newlines should be replaced by Comma as in Thunderbird.  This would allow to paste Newline delimited and Comma delimited address lists directly.  Even lists delimited by Newline+Comma would work, because the newly generated but superfluous commas are thrown away by addressingWidget.js.

Updated

7 years ago
Assignee: mail → nobody
Component: MailNews: Message Display → MailNews: Composition
QA Contact: mailnews-composition

Comment 31

7 years ago
We can now use <textbox newlines="replacewithcommas" ...>
See:
https://developer.mozilla.org/en/XUL/Attribute/newlines
(Assignee)

Updated

7 years ago
Assignee: nobody → ewong
Status: NEW → ASSIGNED
(Assignee)

Comment 32

7 years ago
Created attachment 524948 [details] [diff] [review]
Changed CR to commas.
Attachment #524948 - Flags: review?
(Assignee)

Updated

7 years ago
Attachment #524948 - Flags: review? → review?(mnyromyr)

Updated

7 years ago
Attachment #524948 - Flags: superreview+
Attachment #524948 - Flags: review?(mnyromyr)
Attachment #524948 - Flags: review+

Updated

7 years ago
Keywords: checkin-needed

Comment 33

7 years ago
Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/f3b2f4fad589
Pushed to comm-20:
http://hg.mozilla.org/releases/comm-2.0/rev/0a9a6fbc0dd5
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1final

Updated

7 years ago
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.