Removing bookmark will unpin and remove website from Home page

RESOLVED FIXED in Firefox 31

Status

()

RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: angelc04, Assigned: liuche)

Tracking

Trunk
Firefox 31
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reproduce steps:
1. Launch Fennec and open a website
2. Pin this website to Top sites
3. Browse this website and add it to bookmarks
4. Check about:home, this website is pinned in topsites
5. Click on this website, and click ok the "Star" to remove it from Bookmarks
6. Go to About:Home again
   => This wensite is unpinned and removed from topsites

Expected behavior:
Websites should remain on Home page and stay as pinned

Devices used:
Sumsung Galaxy S3 I9300, Android 4.0.4
Sumsung GT-P7510, Android 4.0.4
Android 4.2.2; Nexus 7
Just a note. Future home page designs will only allow thumbnails (and therefore pinning) of bookmarks. So in the future this won't be a bug.

However, as it stands right now, this seems like a bug.
Assignee: nobody → wjohnston
The future is here! Do we still consider this a bug?
An update to the actual results in comment #1 from what I'm seeing is that the site will remain a top-site just not pinned. UX call I think on wether the item should still be pinned?
Flags: needinfo?(ibarlow)
Version: Firefox 20 → Trunk
Wow, that's quite an edge case :)

I'm not sure there really is a right or wrong answer here. On the one hand, if I pin a site that isn't a bookmark, it is also automatically turned into a bookmark, so the two actions are somewhat linked. On the other hand, deliberately pinning an item seems like a stronger action than bookmarking and I could see how removing the pin automatically when the bookmark is removed could feel undesirable. 

As long as it doesn't create a total mess of logic for our home screen, I would be happy to see pins stay intact even if its corresponding bookmark is removed.
Flags: needinfo?(ibarlow)
Created attachment 8409718 [details] [diff] [review]
Patch: Keep site pinned on unbookmarking
Assignee: wjohnston → liuche
Status: NEW → ASSIGNED
Attachment #8409718 - Flags: review?(margaret.leibovic)

Comment 6

4 years ago
Comment on attachment 8409718 [details] [diff] [review]
Patch: Keep site pinned on unbookmarking

Review of attachment 8409718 [details] [diff] [review]:
-----------------------------------------------------------------

I thought we already did this, but I must be thinking of some other edge case we fixed. These magical bookmark folders are a source of trouble.
Attachment #8409718 - Flags: review?(margaret.leibovic) → review+
https://hg.mozilla.org/mozilla-central/rev/48645ff1f93e
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 917770
You need to log in before you can comment on or make changes to this bug.