Closed Bug 917770 Opened 8 years ago Closed 7 years ago

User pinned sites are removed if the bookmark is removed

Categories

(Firefox for Android Graveyard :: Awesomescreen, defect)

All
Android
defect
Not set
normal

Tracking

(firefox25 affected, firefox26 affected)

RESOLVED DUPLICATE of bug 856565
Tracking Status
firefox25 --- affected
firefox26 --- affected

People

(Reporter: AdrianT, Assigned: liuche)

References

Details

Aurora 26.0a1 2013-09-18
Samsung Galaxy Tab 2 (Android 4.1.1)

Steps to reproduce:
1) Bookmark a website.
2) Pin the bookmark in the Top Bookmarks section
3) Remove the bookmark either from the context menu or from the menu

Expected results:
The bookmark is removed but since the user explicitly pinned the website the pinned website is not removed

Actual results:
The pinned site is removed
OS: All → Android
Hardware: ARM → All
Invalid provided the upcoming changes, Lucas?
Flags: needinfo?(lucasr.at.mozilla)
Yep, going away once the changes land.
Depends on: 917455
Flags: needinfo?(lucasr.at.mozilla)
I think things here have even changed since bug 917455 landed... lucasr, can we just close this?
Flags: needinfo?(lucasr.at.mozilla)
I haven't look at the code but this looks like a bug in the way we implemented the 'remove' action in the bookmarks panel? The 'remove' action should only remove the specific bookmark entry instead of removing all bookmarks matching that url (because pinned sites are stored as bookmarks).
Flags: needinfo?(lucasr.at.mozilla)
Chenxia, can you look into this?
Flags: needinfo?(liuche)
Flags: needinfo?(liuche)
QA Contact: liuche
Assignee: nobody → liuche
QA Contact: liuche
I started to try to fix this, but realized that I can't actually repro it - this is actually a dupe of bug 856565, which has been fixed for a while.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 856565
(In reply to Chenxia Liu [:liuche] from comment #6)
> I started to try to fix this, but realized that I can't actually repro it -
> this is actually a dupe of bug 856565, which has been fixed for a while.
> 
> *** This bug has been marked as a duplicate of bug 856565 ***

Excellent :) Thanks for investigating!
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.