Closed Bug 856571 Opened 7 years ago Closed 7 years ago

Move accesskey for Error Console's filter box back

Categories

(Toolkit Graveyard :: Error Console, defect)

defect
Not set

Tracking

(firefox22 fixed, firefox23 verified)

RESOLVED FIXED
mozilla23
Tracking Status
firefox22 --- fixed
firefox23 --- verified

People

(Reporter: neil, Assigned: neil)

References

Details

Attachments

(2 files)

Bug #801266 moved the accesskey for the Error Console's filter box to the new label. However SeaMonkey needs to be able to overwrite the access key (F, E and T are reserved by the menu that we overlay onto the Error Console) so we either need a new id for the label (which is awkward) or more simply just move the access key back to the filter box.
Attached patch Proposed patchSplinter Review
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #731925 - Flags: review?(dao)
Comment on attachment 731925 [details] [diff] [review]
Proposed patch

This prevents the access key from being underlined in the label.
Attachment #731925 - Flags: review?(dao) → review-
Attached image Screen shot
Seems fine to me, this is with the SeaMonkey overlay of course, but I can get you a screen shot without the overlay if you like.
Attachment #732276 - Flags: feedback?(dao)
Comment on attachment 731925 [details] [diff] [review]
Proposed patch

Hm, yeah, actually building with this patch seems to work. I previously moved the accesskey from the label to the textbox using DOM inspector, which removed the underline.
Attachment #731925 - Flags: review- → review+
Attachment #732276 - Flags: feedback?(dao)
Indeed, the attribute isn't live, although I think you can achieve a similar affect by removing and re-adding the label to the DOM.
Pushed mozilla-central changeset b31bfbb2bdc4.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Comment on attachment 731925 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 801266
User impact if declined: Access key is wrong in SeaMonkey
Testing completed (on m-c, etc.): Baked on m-c for over a week
Risk to taking this patch (and alternatives if risky): None
String or IDL/UUID changes made by this patch: None
Attachment #731925 - Flags: approval-mozilla-aurora?
Attachment #731925 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: checkin-needed
Whiteboard: [c/n: b31bfbb2bdc4 to m-a]
Verified as fixed on FF 23 beta 9 (build ID:20130725195523)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20100101 Firefox/23.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20100101 Firefox/23.0
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.