Top of high resolution sprite is showing

RESOLVED WORKSFORME
(NeedInfo from)

Status

()

defect
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: todd, Unassigned, NeedInfo)

Tracking

({regression})

28 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(2 attachments)

Reporter

Description

6 years ago
Posted file sprite-test.htm
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.43 Safari/537.31

Steps to reproduce:

I developed a higher resolution image that will have decent clarity in mobile devices that could also be used on the desktop.


Actual results:

Firefox shows the bottom 1 pixel line of the top image in the vertical sprite stack during hover state.


Expected results:

None of the top image should be showing and the hover state should display as it does in all the other modern browsers.

Updated

6 years ago
Attachment #732036 - Attachment mime type: text/plain → text/html

Comment 1

6 years ago
I'm not able to reproduce the issue with Nightly Firefox 22. Could you download it (see http://nightly.mozilla.org/) and confirm it's fixed on your side too?
Flags: needinfo?(todd)

Comment 2

6 years ago
Sorry, forget my previous comment. The 1-pixel line is visible in FF22.
Flags: needinfo?(todd)

Comment 3

6 years ago
Sounds like a dup of bug 845543

Comment 4

6 years ago
I don't think so.

Regression range:
m-c
good=2012-09-30
bad=2012-10-01
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a680fd777c3b&tochange=beee809b7ade

Suspected bug:
Bug 486918 - Awful image quality in image scaling
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Updated

6 years ago
Component: Untriaged → ImageLib
Product: Firefox → Core
Assignee: nobody → joe

Updated

6 years ago
Version: 19 Branch → 18 Branch
Assignee: joe → nobody

Comment 5

6 years ago
Subtle, but still visible in Fx 28 / Win7 VM.

WFM in Fx 26b2 / Mac.
Version: 18 Branch → 28 Branch

Comment 6

6 years ago
After checking out Bug 486918, if I disable "image.high_quality_downscaling.enabled", the issue goes away. 

Can you please confirm? You should not need to restart Fx after flipping the pref.
Flags: needinfo?(todd)

Comment 7

6 years ago
Bug 795378 will refactor the scaler, so you may want to recheck when that work lands.

(No more bugspam for now, sorry!)
Blocks: 486918
See Also: → 795378
I can't reproduce this locally and so I am closing this bug given comment 7. Please reopen this bug if it still reproduces for you with a current Firefox version.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Whiteboard: [gfx-noted]
You need to log in before you can comment on or make changes to this bug.