Closed Bug 857409 Opened 8 years ago Closed 8 years ago

Border colors are ignored on <input type=file>

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 253690
Tracking Status
firefox22 - affected

People

(Reporter: MattN, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached file Test case 1
Since the recent switch to the new <input type=file> without the textbox, border colors specified by authors are no longer displayed. A border is often used to highlight an invalid field (e.g. using @required) so this will break websites that rely on the field's color to highlight a missing file.

border-style and border-width not working is bug 253690 and recently changed.
Why does forms.css still has an !important for border-style? (according to firebug)

input[type="file"] {
    -moz-appearance: none;
    -moz-binding: none;
    border-style: none !important;
/*...*/
}
Attachment #732635 - Attachment filename: file_857409.txt → file_857409.htm
Attachment #732635 - Attachment mime type: text/plain → text/html
This should be fixed in the patch in bug 52500.
Assignee: nobody → mounir
Status: NEW → ASSIGNED
Version: 22 Branch → Trunk
I just realised this is actually a dup of bug 253690.
Assignee: mounir → nobody
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
No longer depends on: input[type=file]
Resolution: --- → DUPLICATE
Duplicate of bug: 253690
You need to log in before you can comment on or make changes to this bug.