[WORKAROUND] linux flash plugin can't find ESD socked (no sound)

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P3
normal
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Stephane Chauveau, Assigned: Peter Lubczynski)

Tracking

({relnote})

Trunk
Future
x86
Linux
relnote
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL2:Vendor][THIS IS A FLASH ISSUE -- NOT A MOZILLA ISSUE])

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
What I describe here is obviously a bug in the flash plugin for linux
and not a bug in mozilla. However, describing the problem and the solution
here may help a few mozilla users.

The effect is simple: no sound at all in flash. The reason ? 
On Debian (unstable) and may be other distributions the esd socket file 
has been moved from /tmp/.esd/socket to /var/run/esound/socket.
This change is normally resolved automatically by the dynamic library 
libesd.so but the flash plugin is statically linked with an old version 
using /tmp/.esd/socket. 

A temporay workaround is to create a symlink from /tmp/.esd to
/var/run/esound 

ln -s /var/run/esound /tmp/.esd

remark that on debian the user must be added to the 'audio' group to be 
able to use ESD.
Keywords: relnote

Comment 1

16 years ago
marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: linux flash plugin can't find ESD socked (no sound) → [WORKAROUND] linux flash plugin can't find ESD socked (no sound)

Comment 2

16 years ago
related to bug 58339 ?
(Reporter)

Comment 3

16 years ago
Yes and no :-) 

The initial bug 58339 describes a problem when esd is used by multiple
applications while my workaround is about a change in the location of the 
esd socket. When I read the comments in 58339 I have the impression that
peoples are confused by what is built in the flash plugin.

The one I am using is Shockwave Flash 5.0 r45. It seems to be statically 
linked with an old version of esd:

chauveau@tolkien:~/.moz_plugins$ ldd libflashplayer.so 
        statically linked
chauveau@tolkien:~/.moz_plugins$ strings libflashplayer.so | grep esd
esd_open_sound
esd_get_server_info
esd_free_server_info
esd_play_stream
esd_close
esd_set_socket_buffers
esd_send_auth
esd_lock
esd_unlock
esd_standby
esd_resume
esd_config_read
esd_no_spawn
esd_spawn_options
esd_play_stream_fallback
esd_audio_format
esd_audio_rate
esd_audio_open
esd_monitor_stream
esd_filter_stream
esd_record_stream
esd_record_stream_fallback
esd_sample_cache
esd_confirm_sample_cache
esd_sample_getid
esd_sample_free
esd_sample_play
esd_sample_loop
esd_sample_stop
esd_print_server_info
esd_print_player_info
esd_print_sample_info
esd_print_all_info
esd_get_all_info
esd_free_all_info
esd_subscribe_all_info
esd_update_info
esd_unsubscribe_info
esd_set_stream_pan
esd_set_default_sample_pan
esd_get_standby_mode
esd_audio_device
esd_audio_devices
esd_audio_pause
esd_audio_close
esd_audio_write
esd_audio_read
esd_audio_flush
/.esd_auth
/tmp/.esd/socket
esd %s
- esd_subscribe_all_info: not yet implemented!
- esd_update_info: not yet implemented!
- esd_unsubscribe_info: not yet implemented!
/usr/etc/esd.conf
%s/.esd.conf



Comment 4

16 years ago
--- Mass reassigning Unix bugs to serge ---
Assignee: av → serge

Updated

16 years ago
Target Milestone: --- → mozilla1.0.1

Comment 5

16 years ago
Hi, I'm not sure if I should be posting to this bug or to #58339, however someone
posted a comment in 58339 as a work around:

artsdsp /usr/local/mozilla/mozilla 

I'd just like to confirm this DOES IN FACT work!!!!  I'm using mozilla 0.9.7,
RH72, and Shockwave Flash 5.0 r47.  I'm using KDE2.

Updated

15 years ago
Whiteboard: [Flash]
Target Milestone: mozilla1.0.1 → mozilla1.2alpha

Comment 6

15 years ago
Hi all,
  Found a very simple way of sorting this problem out well it works for me, the
problem is with the aRts Sound Server, but u do not need to disable it, simply
click where it says Autosupend if idle for and set the timing to 1 second that
should fix it unless u activate flash within 1 second of the sound server.  Not
sure what else uses the sound server but all by sound works fine will using flash.

Hope that works on other systems, if no try disabling what you have running the
arts server all the time.

Comment 7

15 years ago
related to bug 58339, this is a flash issue and not a mozilla issue
Priority: -- → P3
Whiteboard: [Flash] → [THIS IS A FLASH ISSUE -- NOT A MOZILLA ISSUE]
Target Milestone: mozilla1.2alpha → Future

Updated

15 years ago
Whiteboard: [THIS IS A FLASH ISSUE -- NOT A MOZILLA ISSUE] → [PL2:Vendor][THIS IS A FLASH ISSUE -- NOT A MOZILLA ISSUE]

Comment 8

15 years ago
reassign
Assignee: serge → beppe

Updated

15 years ago
Blocks: 139820

Comment 9

15 years ago
Flash player 5.0.51 (released on Sep 11 2002) now longer includes esound code..
I think this bug can be closed.

Comment 10

15 years ago
reassign
Assignee: beppe → peterl

Comment 11

14 years ago
Created attachment 131045 [details]
sometimes Flash sound works, sometimes it doesn't, if it doesn't, try again
I have upgraded to flash 6.0. By the moment, everything seems to work. Unless
there's any problematic URL I can try, it works for me.

Comment 13

14 years ago
Marking WFM due to the last comment.
Reopen if your opinion is different and you can reproduce this with a
current build.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.