Closed Bug 139820 Opened 20 years ago Closed 15 years ago

[META] Macromedia flash player known problems which hard or impossible to fix in mozilla code

Categories

(Core :: Plug-ins, defect, P3)

defect

Tracking

()

RESOLVED WONTFIX
Future

People

(Reporter: srgchrpv, Assigned: peterl-bugs)

References

Details

(Keywords: meta, Whiteboard: [PL2:NA][Flash Meta Tracking Bug])

this is mata bug to keep track of macromedia flash player bugs for all platform,
which probably cannot be fixed w/o access to flash plugin code.
adding bug 58339 (linux/unix)
[Flash plugin (presumably 5.0 r47 only) hangs mozilla, when it's trying to play 
audio, while audio device is active. (Reproducible with some [e.g. es1371] sound 
driver)]
The work around is to use old flash 4.0, posted into 58339 bug report,
see comment #135, 194, 195, 196, 233
Depends on: 58339
bug 58937 (linux/unix) [Flash crashes with exported X display]
Depends on: 58937
Keywords: meta
bug 87707 (all platform)
[crash when viewing context menu while index page is about to load]
Depends on: 87707
bug 92012 (linux/unix)
[Flash on ultrapasswordz.com crashes browser on Linux]
Depends on: 92012
Depends on: 139698
Depends on: 140686
Adding two dependencies, hope this is OK.


bug 110441 (probably all platforms)
[can't script Flash through Javascript]

See comment #32 there: http://bugzilla.mozilla.org/show_bug.cgi?id=110441#c32


bug 112684
[Macromedia needs to update Flash to be scriptable through XPConnect]

See comment  #6 there: http://bugzilla.mozilla.org/show_bug.cgi?id=112684#c6
Depends on: 110441, 112684
No longer depends on: 112684
Whiteboard: [Flash Meta Tracking Bug]
Priority: -- → P3
Whiteboard: [Flash Meta Tracking Bug] → [PL2:NA][Flash Meta Tracking Bug]
Target Milestone: --- → mozilla1.1alpha
Target Milestone: mozilla1.1alpha → mozilla1.2alpha
Depends on: 85772, 90471, 100%CPU, 155601, 156425
Depends on: 46569
Depends on: 154427
Added IME bug, and wmode bug, for completeness.
Depends on: 129895
No longer depends on: 129895
adding bug 165691
Depends on: 165691
Depends on: 166206
Depends on: 166717
Still freezing even with Macromedia Flash Player 6.0 Beta...I made this test
with www.ford.it, that with 5.0 didn't work at all, now I can enter the site,
but in the car configuration page, I get a freeze
Blocks: 175904
Depends on: 176228
moving this out to future, to account for unresolved open issues
Target Milestone: mozilla1.2alpha → Future
reassign
Assignee: beppe → peterl
I think Bug 191003 and Bug 195918 (probably a duplicate of 191003) are also
possible dependencies of this bug.
Flashplayer 7 doesn't appear to work well in Mozilla 1.4,1.5,1.6, Netscape 7.1.
Some images just don't show up. Some flash doesn't work.
Depends on: 211213
Would bug 228228 be an appropriate blocker for this?
outdated and such
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.