Failed DNS lookup results in segfault

VERIFIED FIXED in mozilla0.9.2

Status

()

Core
Networking
P2
blocker
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Steve, Assigned: gordon)

Tracking

({crash})

Trunk
mozilla0.9.2
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: r=gagan, sr=brendan, a=?, URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Immediately after pulling in todays DNS fixes (06/13/2001 16:33 in bonsai),
attemping to access a non-existing site results in a segfault.
-> Networking
Assignee: asa → gordon
Component: Browser-General → Networking
QA Contact: doronr → benc

Updated

17 years ago
Keywords: crash
(Assignee)

Updated

17 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P2
Target Milestone: --- → mozilla0.9.2

Comment 2

17 years ago
Is this the same as bug 85806?
(Assignee)

Comment 3

17 years ago
No, this was a harmless race condition that my last checkin made not so
harmless.  I can fix this on Thursday.

Comment 4

17 years ago
*** Bug 85862 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
i'm marking this mostfreq because it will be mostfreq w/in a 48 hours.
Keywords: mostfreq
(Assignee)

Comment 6

17 years ago
Created attachment 38454 [details] [diff] [review]
patch to fix race condition, take 1.
(Assignee)

Comment 7

17 years ago
I've tested the patch on Mac, Linux, and WindowsNT.  Looking for reviewers.

Comment 8

17 years ago
the processing flag needs to be incremented and decremented since other threads
can be active in the same funtion at that time. with that change it seems ok.
r=gagan
(Assignee)

Comment 9

17 years ago
Created attachment 38499 [details] [diff] [review]
fix to incremment/decrement mProcessingRequests counter rather than flag.
(Assignee)

Comment 10

17 years ago
I have an sr=brendan as well.
Whiteboard: r=gagan, sr=brendan, a=?

Comment 11

17 years ago
a= asa@mozilla.org for checkin to the trunk.
(on behalf of drivers)
Blocks: 83989
(Assignee)

Comment 12

17 years ago
Patch checked in.  Marking FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 13

17 years ago
*** Bug 86121 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
Verified on:

Win2K:  2001-07-27-00-0.9.2
        2001-07-27-12-trunk
MacOS:  2001-07-26-21-0.9.2
Linux:  2001-07-26-23-0.9.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.