Closed Bug 858833 Opened 7 years ago Closed 7 years ago

during an update, downloadAvailable is sometimes not reset to false after an error, when it should

Categories

(Core Graveyard :: DOM: Apps, defect)

22 Branch
ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox21 wontfix, firefox22 wontfix, firefox23 fixed, b2g18+ fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix)

RESOLVED FIXED
mozilla23
Tracking Status
firefox21 --- wontfix
firefox22 --- wontfix
firefox23 --- fixed
b2g18 + fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix

People

(Reporter: julienw, Assigned: julienw)

References

Details

Attachments

(1 file)

STR:
* install a packaged app that you control
* change the update manifest, and corrupt the zip
* check for updates
* accept the update

Expected:
* the update is downloaded and then the notification disappear because the error is not recoverable by the user. After some time a banner shows up explaining there was an error.

Actual:
* the expected behaviour happens, except the notification does not disappear.

This STR should be used with the patch for Bug 837193 which implements the removal of the notification.
Attached patch patch v1Splinter Review
When updating an app, the installState is not "installed" but "updating. So I changed the test to test that it's not "pending" instead, as in other places.

The STR works fine with this change.
Attachment #734125 - Flags: review?(fabrice)
Blocks: 837193
Btw, we've got test automation hooked up in the tree. So bonus points if you include a test.
ok, I'll try to include one.
Comment on attachment 734125 [details] [diff] [review]
patch v1

Review of attachment 734125 [details] [diff] [review]:
-----------------------------------------------------------------

Please file a followup for the tests (we still need to land the packaged apps tests, bug 821589)
Attachment #734125 - Flags: review?(fabrice) → review+
Comment on attachment 734125 [details] [diff] [review]
patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): -
User impact if declined: normally, when a unrecoverable errors happen, the update notification should be removed (see Bug 837193). With this bug, this does not happen for some errors. So this is a low user impact but since the change is small I think this is worth it.
Testing completed: yes
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: none
Attachment #734125 - Flags: approval-mozilla-b2g18?
Keywords: checkin-needed
Blocks: 859258
Filed Bug 859258 for the test.
https://hg.mozilla.org/mozilla-central/rev/e7307ecec02c
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
tracking-b2g18: --- → ?
Attachment #734125 - Flags: approval-mozilla-b2g18? → approval-mozilla-b2g18+
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.