If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Regression: Vertical line on URL bar

VERIFIED FIXED in Firefox 22

Status

()

Firefox for Android
Theme and Visual Design
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: lucasr)

Tracking

({regression})

Trunk
Firefox 23
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(firefox22 fixed, firefox23 verified, fennec23+)

Details

(Whiteboard: ui-hackathon)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 734294 [details]
Nightly (04/06) - Screenshot

Very recent regression. See screenshot.

Sriram bug?

--
Nightly (04/06)
LG Nexus 4 (Android 4.2.2)
tracking-fennec: --- → ?
status-firefox22: --- → unaffected
(Reporter)

Comment 1

5 years ago
I tried a couple devices (Note II, Galaxy Nexus, Nexus S), I think it's a Nexus 4 thing. Anyone else seeing this elsewhere?
I noticed this line on my Nexus 4. Is this bug related to the Nexus 4 display's dpi?
(In reply to Chris Peterson (:cpeterson) from comment #2)
> I noticed this line on my Nexus 4. Is this bug related to the Nexus 4
> display's dpi?

I might be a combination of Nexus 4's dpi (which might be 2.133 or something) and the float calculations.
(Reporter)

Updated

5 years ago
Duplicate of this bug: 859914
tracking-fennec: ? → 23+
(Assignee)

Comment 5

5 years ago
Sriram, maybe a regression from bug 848719?
Dup of bug 860296 ?
(Reporter)

Comment 7

5 years ago
(In reply to Mark Capella [:capella] from comment #6)
> Dup of bug 860296 ?

Nah this one is static, always visible on the bar.
Reported by a user on a HTC One S as well.
(Assignee)

Updated

5 years ago
Whiteboard: ui-hackathon
(Reporter)

Comment 9

5 years ago
Forgot to comment here last week, I noticed that in landscape orientation the vertical line is removed.
Nominating as bug #1 for the UI Hackathon :)

This thing is making my eyes bleed

Comment 11

5 years ago
Do we have a regression range on this bug?
(Reporter)

Comment 12

5 years ago
Yes

http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8fc33d047ed6&tochange=c99b61f740d7
Blocks: 848719
(Assignee)

Updated

5 years ago
Assignee: nobody → lucasr.at.mozilla
Also seen on my HTC Sensation 4G running ICS.
Status: NEW → ASSIGNED
(Assignee)

Comment 14

5 years ago
Created attachment 741559 [details] [diff] [review]
Use DST_IN to draw ShapedButton

It seems that using DST_OUT to draw ShapedButtons might cause subpixel artifacts close to the view boundaries. We can avoid that by using DST_IN instead.
Attachment #741559 - Flags: review?(mark.finkle)
Attachment #741559 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 15

5 years ago
Pushed: https://hg.mozilla.org/integration/mozilla-inbound/rev/72ee55092cb8
https://hg.mozilla.org/mozilla-central/rev/72ee55092cb8
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23

Updated

5 years ago
status-firefox23: affected → fixed
(Assignee)

Comment 17

5 years ago
Comment on attachment 741559 [details] [diff] [review]
Use DST_IN to draw ShapedButton

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 848719
User impact if declined: Visual artifact on browser toolbar in some devices
Testing completed (on m-c, etc.): Landed on m-c, no issues.
Risk to taking this patch (and alternatives if risky): Very low, patch is fairly simple.
String or IDL/UUID changes made by this patch: n/a
Attachment #741559 - Flags: approval-mozilla-aurora?

Updated

5 years ago
status-firefox22: unaffected → affected
Comment on attachment 741559 [details] [diff] [review]
Use DST_IN to draw ShapedButton

regression on Fx22 and has a low risk patch.Approving !
Attachment #741559 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

5 years ago
Keywords: verifyme
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-firefox23: fixed → verified
Keywords: verifyme
(Assignee)

Comment 19

5 years ago
Pushed to aurora: https://hg.mozilla.org/releases/mozilla-aurora/rev/175e1e444db4

Updated

5 years ago
status-firefox22: affected → fixed
You need to log in before you can comment on or make changes to this bug.