Closed Bug 859057 Opened 7 years ago Closed 6 years ago

Add a way to clear all the requests in the network monitor UI

Categories

(DevTools :: Netmonitor, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 28

People

(Reporter: vporof, Assigned: cpaul37)

References

Details

(Whiteboard: [good first bug][mentor=vporof@mozilla.com][lang=js])

Attachments

(1 file)

Push a button. Reduce clutter.
Moving into Developer Tools: Netmonitor component. Filter on NETMONITORAMA.
Component: Developer Tools → Developer Tools: Netmonitor
Summary: [netmonitor] Add a way to clear all the requests in the network monitor UI → Add a way to clear all the requests in the network monitor UI
Is this actually useful? The list of requests is cleared on page navigation anyway.
(In reply to David Creswick from comment #2)
> Is this actually useful? The list of requests is cleared on page navigation
> anyway.

Sometimes the requests keep adding up, for example, on manual POSTs, on hovers (images) etc. In a development process, I often find it useful to clear all the added context and start from scratch, but without refreshing the page.
(In reply to Victor Porof [:vp] from comment #3)
> (In reply to David Creswick from comment #2)
> > Is this actually useful? The list of requests is cleared on page navigation
> > anyway.
> 
> Sometimes the requests keep adding up, for example, on manual POSTs, on
> hovers (images) etc. In a development process, I often find it useful to
> clear all the added context and start from scratch, but without refreshing
> the page.

Okay. Maybe it would be more useful though to have the netmonitor automatically scroll down upon new net transfers, but only when the scroll position is already at the bottom. (That would be useful irrespective of this bug.) I question throwing away information that one might not know one will later want.
(In reply to David Creswick from comment #4)
> 
> Okay. Maybe it would be more useful though to have the netmonitor
> automatically scroll down upon new net transfers, but only when the scroll
> position is already at the bottom. 

Great idea.
Priority: -- → P2
Duplicate of this bug: 874573
I was just looking for this feature.  My pages have polling ajax requests that run every 5 seconds.  After a few minutes, the list is really large and it becomes hard to find the request that I really care about.  With Firebug, my workflow is to clear the list before I fire the requests that I'm working on.  This way, those requests are at the very top and are easy to find.  So either a way to clear the list or a way to filter the list would be nice.
(In reply to Victor Porof [:vp] from comment #5)
> (In reply to David Creswick from comment #4)
> > 
> > Okay. Maybe it would be more useful though to have the netmonitor
> > automatically scroll down upon new net transfers, but only when the scroll
> > position is already at the bottom. 
> 
> Great idea.

If for whatever reason clearing will not be allowed, in addition to scrolling will be helpful to somehow visually separate new requests from previously loaded ones.  This is almost the only way to distinguish how single page web applications interact with the server when using Backbone or ExtJS.
This idea seems to be popular:

https://hacks.mozilla.org/2013/09/reintroducing-the-firefox-developer-tools-part-1-the-web-console-and-the-javascript-debugger/comment-page-1/#comment-2153333

I can definitely see the utility of being able to clear away requests as you continue to use a single page  app that uses REST apis or the like. Should we bump the priority of this?
This is also very useful for debugging the main process: There is no reload in this case, so network requests just pile up. I'd love for this to be bumped for the sake of debugging connections inside Thunderbird.
okay
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Duplicate of this bug: 926039
Marking this as being a good first bug, because it's easy.
Assignee: vporof → nobody
Status: ASSIGNED → NEW
Whiteboard: [good first bug][mentor=vporof@mozilla.com][lang=js]
Added a clear button next to the summary text (I wasn't sure where it should go).
Attachment #8336584 - Flags: review?(vporof)
Ooh, thank you so much for working on this! I'll add you as the assignee and review your patch asap.
Assignee: nobody → cpaul37
Status: NEW → ASSIGNED
Comment on attachment 8336584 [details] [diff] [review]
net_monitor_clear_button.patch

Review of attachment 8336584 [details] [diff] [review]:
-----------------------------------------------------------------

Beautiful work! Thank you!
Attachment #8336584 - Flags: review?(vporof) → review+
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/ab3aecf99fe4
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [good first bug][mentor=vporof@mozilla.com][lang=js] → [good first bug][mentor=vporof@mozilla.com][lang=js][fixed-in-fx-team]
\o/ woo, thanks Cameron! People have really been asking for this.
https://hg.mozilla.org/mozilla-central/rev/ab3aecf99fe4
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [good first bug][mentor=vporof@mozilla.com][lang=js][fixed-in-fx-team] → [good first bug][mentor=vporof@mozilla.com][lang=js]
Target Milestone: --- → Firefox 28
See Also: → 925275
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.