Closed Bug 85908 Opened 21 years ago Closed 19 years ago

Add reload to View Page Source Window

Categories

(Core Graveyard :: View Source, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.6alpha

People

(Reporter: bugzilla, Assigned: doronr)

References

Details

(Keywords: polish)

Attachments

(1 file, 2 obsolete files)

View Source window should have View -> Reload
confirming rfe.
Blocks: 79518
Status: UNCONFIRMED → NEW
Ever confirmed: true
i tryed to fix with adding

<menuitem accesskey="&reloadCmd.accesskey;" key="key_reload"
label="&reloadCmd.label;" command="Browser:Reload"/>

but no result. where is the problem ? i try to understand this holy mass of
code, ohh thats so complicated... :)
i actually had this working once, I think timeless asked it.  However, i still
fail to see a realy use for it, especially since i had to cut "open welocation"
from the viewsource UI.
--> doron
Assignee: blake → doronr
*** Bug 118317 has been marked as a duplicate of this bug. ***
mass moving open bugs pertaining to view source to pmac@netscape.com as qa contact.

to find all bugspam pertaining to this, set your search string to
"ItsSharkeysNight".
QA Contact: sairuh → pmac
*** Bug 143215 has been marked as a duplicate of this bug. ***
--> ViewSource
Component: XP Apps: GUI Features → ViewSource
Attached patch Proposed patch (obsolete) — Splinter Review
Keywords: patch, polish, review, ui
Hmm... reload doesn't seem to have quite the effect I want. Maybe I should just
go with reload skip cache all the time.
Comment on attachment 89381 [details] [diff] [review]
Proposed patch

Don't call functions BrowserFoo in viewsource :)
Attachment #89381 - Flags: needs-work+
Just noting that I'm hoping the fix will also support CTLR-R reloads. -I use
that left and right on NS4. :->
Hrm.  Cache. Right.  The current implementation of nsViewSourceChannel will
_always_ try to read from cache if possible.  You may have to deal with that if
you want this to actually reload from network....
Doron, sorry, I was hoping to get F5 automatically - F5 calls BrowserReload().
Unfortunately I'd forgotton to overlay platformNavigationBindings.xul :-)
Attached patch Fix F5 (obsolete) — Splinter Review
Also always skips cache.
Attachment #89381 - Attachment is obsolete: true
I still don't see you overlaying anything
> I still don't see you overlaying anything

In fact I was overlaying (it's not explicit) I just wasn't pulling the key in :-)
Requesting blocking 1.4. We got a patch, lets review and get it in if it is good.
Flags: blocking1.4?
Flags: blocking1.4? → blocking1.4-
Is this realllly needed?  Care to explain why this is needed?

Also, I think edit page in viewsource should go :)
This is very usefull for programming of dynamic web sites.
To the question of "why is it needed"; Code-level web developers, i.e. JSP, PHP,
PERL, ASP, etc) frequently need to debug the raw output from the webserver when
they make changes -- just viewing the changes on the rendered page is of
marginal value (take XML or XSL output for example). Without this feature, code
writers are relagated to having to:

1) make changes server-side
2) reloading the URL (ctrl-r or f)
3) view source (ctrl-u)
4) scroll-to and review the code segment in question
5) close the old (stagnate) view source window
6) focus on the rendered (main) browser window, and repeat as neccesary

compared to:
1) view source, just one time (ctrl-u) 
2) reload view source window (ideally, without need to re-scroll to the code in
question, similar to the behavior of the main window when reloading)
3) make changes server-side, --> step 2 as neccesary
4) close the view source window (just one time), after fixing code in question.
hmm. Neil, can you rename the functions to not contain 
"browser" :)
BTW View source in NN4.78 has this feature.
Keywords: 4xp
OS: other → All
Comment on attachment 89673 [details] [diff] [review]
Fix F5

+      <menu id="tasksMenu"/>

Why are you adding all these menus?  Also, please change the name of the
functions to be ViewSource* perhaps.
Attachment #89673 - Flags: review-
Since this is a 4xp bug, shouldn't it be a normal bug and not an "enhancement
request" ? BTW, if it could land for 1.4, it would be great since this feature
would be one more argument in favor of Mozilla/Netscape for evangelizing web
developpers.
I found this usefull :
http://placenamehere.com/pnhtoolbar/
In the toolbar, there's a "view-source" that open a tab with the source.

with SHIFT+CTRL+R it's possible to reload from the source.

It works with Phoenix 0.5 Fr and Netscape 7.02 FR
Comment on attachment 89673 [details] [diff] [review]
Fix F5

I can't rename the functions because that's what F5 and Ctrl+F5 expect to use.
Attachment #89673 - Flags: review- → review?(doronr)
hmm, why the tasks menu then? other than that its fine.
Attached patch Removed tasksSplinter Review
Attachment #89673 - Attachment is obsolete: true
Attachment #130068 - Flags: superreview?(bz-vacation)
Attachment #130068 - Flags: review?(doronr)
Comment on attachment 130068 [details] [diff] [review]
Removed tasks

looks fine to me.
Attachment #130068 - Flags: review?(doronr) → review+
Comment on attachment 130068 [details] [diff] [review]
Removed tasks

sr=me; test well to make sure this really does reload the source...
Attachment #130068 - Flags: superreview?(bz-vacation) → superreview+
Target Milestone: --- → mozilla1.6alpha
Fix checked in.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
It almost works - for me, I get a cached view of a dynamic content URL. A good
example is a login page where the login form URL stays the same after the person
logs in - I noticed some other bugs stating that the view srource window isnt
sending cookies - guessing this is the cause. Otherwise AWESOME!!!! :)
Attachment #89673 - Flags: review?(doronr)
*** Bug 225510 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.