Mouse exit must be generated when mouse leaves apprunner window

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
20 years ago
20 years ago

People

(Reporter: rods, Assigned: pavlov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
I will be closing out Bug #3175, but for it to work on GTK the proper exit event
must be generated. I am under the impression that a final mouse exit event is
NOT being generated when the mouse leaves the app window. (See comments under
Bug 3175). If it is then kill this bug.

Comment 1

20 years ago
*** Bug 8593 has been marked as a duplicate of this bug. ***

Comment 2

20 years ago
Moving all Widget Set bugs, past and present, to new HTML Form Controls
component per request from karnaze.  Widget Set component will be retired
shortly.

Comment 3

20 years ago
phillip, linux only?  Looks like ALL..yes?

Comment 4

20 years ago
actually, i got in trouble with this before. this is a linux only bug because
the way to fix it is by using GTK. there is a mac only version of this bug,
which was separated due to the fact that different engineers are working on it.
that happens to be bug 8592. i do not no, but am pretty sure that the event
is generated in windows. so this should remain a PC/Linux only bug.

Updated

20 years ago
Assignee: ramiro → pavlov
Component: HTML Form Controls → XP Toolkit/Widgets
(Assignee)

Updated

20 years ago
Target Milestone: M9
(Assignee)

Comment 5

20 years ago
I feel very certain that we are.  I will double check this tomorrow and close it
then.
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 6

20 years ago
this works for me
You need to log in before you can comment on or make changes to this bug.