Last Comment Bug 859287 - After the toolbar customization dialog is used, the "Get Mail" pull down does not display full width until TB is restarted.
: After the toolbar customization dialog is used, the "Get Mail" pull down does...
Status: RESOLVED FIXED
: regression
Product: Thunderbird
Classification: Client Software
Component: Toolbars and Tabs (show other bugs)
: 21 Branch
: All All
: -- minor (vote)
: Thunderbird 23.0
Assigned To: :aceman
:
:
Mentors:
Depends on:
Blocks: 813218
  Show dependency treegraph
 
Reported: 2013-04-08 05:38 PDT by Josiah Bruner [:JosiahOne] (needinfo for responses)
Modified: 2013-04-14 18:25 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screenshot of the bug. (18.44 KB, image/png)
2013-04-08 05:38 PDT, Josiah Bruner [:JosiahOne] (needinfo for responses)
no flags Details
patch (3.06 KB, patch)
2013-04-10 13:07 PDT, :aceman
mkmelin+mozilla: review+
Details | Diff | Splinter Review

Description Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-04-08 05:38:49 PDT
Created attachment 734572 [details]
Screenshot of the bug.

On the current Daily (V. 23), when using the Icon Only mode, the get mail pull down menu does not display it's full width and dramatically cuts off the names of each account.

The issue does *not* occur on Thunderbird V. 17.0.5.

Attached is a screenshot of the issue.
Comment 1 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-04-08 05:40:08 PDT
Odd, after trying again, I can not reproduce it. Going to try to find the cause of this...
Comment 2 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-04-08 05:42:33 PDT
Ah, there we go. This issue still happens only on V. 23, but only occurs when the first click after you change the tab icon type. (E.G. Text to Text beside icons, etc).
Comment 3 :aceman 2013-04-10 03:04:04 PDT
Confirming on Win XP. After restart of TB with the Icons only mode, the popup is fine.

It also happens just after switching from Icons only to "Icons beside text" mode.

So it happens after any switch.

I wonder if this isn't caused by bug 860093.
Josiah, maybe you could try the trivial change proposed in bug 860093 and see if it helps.
Comment 4 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2013-04-10 05:56:22 PDT

*** This bug has been marked as a duplicate of bug 860093 ***
Comment 5 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-04-10 07:39:17 PDT
Re-opening bug. Tried the patch and it does not fix the issue.
Comment 6 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2013-04-10 10:44:18 PDT
I can reproduce on latest beta, aurora and daily. Looking onto the list of patches in bug 824150 which landed until mid-February, I don't think that this is a regression by that bug.
Comment 7 :aceman 2013-04-10 11:34:57 PDT
I get this error when closing the Customize palette:
Error: TypeError: toolbox.getElementById is not a function
Source file: chrome://messenger/content/mailCore.js

But bug 860093 does not fix the problem here.

I think this may be fallout from bug 813218. Who would have expected the Get Mail menupopup parasites on a folder picker :)
Comment 8 Richard Marti (:Paenglab) 2013-04-10 11:57:50 PDT
When switching the mode the button-getMsgPopup gets a width="100" on Win7 (not checked other platform but it would be the same) which makes the small popup. After reboot no width is set.
Comment 9 :aceman 2013-04-10 12:09:31 PDT
Yes, that's the new code added in bug 813218. When we get into the customize mode (have id.startsWith("wrapper")) I set width=100 and save the original width in another attribute. But for this popup the original width is never restored back after leaving the customize mode.

I'm on it.
Comment 10 :aceman 2013-04-10 13:07:47 PDT
Created attachment 735933 [details] [diff] [review]
patch

This seems to do it.
Josiah, can you confirm?
Comment 11 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-04-10 13:18:59 PDT
(In reply to :aceman from comment #10)
> Created attachment 735933 [details] [diff] [review]
> patch
> 
> This seems to do it.
> Josiah, can you confirm?

Yep, issue fixed. Thanks Ace.
Comment 12 neil@parkwaycc.co.uk 2013-04-10 13:48:00 PDT
Comment on attachment 735933 [details] [diff] [review]
patch

Sorry, I can't review this because I don't have a test case
(Thunderbird doesn't count to me as a test case).
Comment 13 :aceman 2013-04-10 14:01:22 PDT
(In reply to Josiah Bruner [:JosiahOne] from comment #2)
> Ah, there we go. This issue still happens only on V. 23, but only occurs
> when the first click after you change the tab icon type. (E.G. Text to Text
> beside icons, etc).

If this is really a regression from bug 813218 then this should happen since TB21. And for me it is enough to just open the Customize dialog and clicking Done.
Comment 14 :aceman 2013-04-10 14:15:37 PDT
(In reply to neil@parkwaycc.co.uk from comment #12)
> Sorry, I can't review this because I don't have a test case
> (Thunderbird doesn't count to me as a test case).
OK, I see Seamonkey's Get mail menulist is made via rdf, not the folder picker.
Comment 15 Magnus Melin 2013-04-13 12:44:39 PDT
Comment on attachment 735933 [details] [diff] [review]
patch

Review of attachment 735933 [details] [diff] [review]:
-----------------------------------------------------------------

Seems to fix it! r=mkmelin
Comment 16 Ryan VanderMeulen [:RyanVM] 2013-04-14 18:25:02 PDT
https://hg.mozilla.org/comm-central/rev/41b14c833e76

Note You need to log in before you can comment on or make changes to this bug.