Closed Bug 859686 Opened 7 years ago Closed 7 years ago

Checkbox in Style Rule view are not drawn properly on Windows 7

Categories

(DevTools :: Inspector, defect)

22 Branch
x86_64
Windows 7
defect
Not set

Tracking

(firefox21 unaffected, firefox22+ verified, firefox23+ verified, firefox24 verified)

VERIFIED FIXED
Firefox 23
Tracking Status
firefox21 --- unaffected
firefox22 + verified
firefox23 + verified
firefox24 --- verified

People

(Reporter: alice0775, Assigned: miker)

References

Details

(Keywords: regression)

Attachments

(2 files)

Build Identifier:
http://hg.mozilla.org/releases/mozilla-aurora/rev/05e799145245
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130408 Firefox/22.0 ID:20130408004015

Steps to Reproduce:
1. Make sure desktop style Windows7 Classic
2. Start Firefox
3. Launch Dom Inspector
4. Click Checkbox in Style Rule view

Actual result:
Checkbox is always white rectangle, no check mark appears.

Expected Results:
check mark should be toggled (appear/disappear).

Regression window:
Good:
http://hg.mozilla.org/integration/fx-team/rev/f09e10680ee4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130327 Firefox/22.0 ID:20130327083604
Bad:
http://hg.mozilla.org/integration/fx-team/rev/36332ce24dd1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130327 Firefox/22.0 ID:20130327152206
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=f09e10680ee4&tochange=36332ce24dd1

Regressed by: Bug 836233
Happens on Windows 7 Aero mode also.
Summary: Checkbox in Style Rule view are not drawn properly on Windows7 Classic style → Checkbox in Style Rule view are not drawn properly on Windows 7
Does anybody have a screenshot?
Attached image screenshot
Attached image screenshot
The checkbox is not hovered. It is missing the cross. Using DOMi, I don't even see a background image property to the icon.
Yes, the reason I asked is because I wanted to check if this was the old or the new theme. I think that the cross in the checkbox is confusing anyhow ... a cross next to something normally erases, rather than disables it.

I suspect that an image, something like Firebug uses, is better.
Why use themed checkboxes?
Because native ones look terrible with the dark theme (styling options are very limited).
No longer blocks: 836233
URL: 855502
Depends on: 855502
Michael - can you take a look in Paul's absence?
Assignee: nobody → mratcliffe
Yes, I am fixing this as part of bug 855502.
This was fixed as part of bug 855502.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Verified as fixed on Windows 7, 64 bits, with Aurora 23.0 and latest Nightly 24.0:

- User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130519 Firefox/23.0, Build ID: 20130519004019

- User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:24.0) Gecko/20130519 Firefox/24.0, Build ID: 20130519031035
Status: RESOLVED → VERIFIED
Duplicate of this bug: 874031
Is it going to be fixed in Firefox 22 too?
Flags: needinfo?(mratcliffe)
(In reply to Loic from comment #13)
> Is it going to be fixed in Firefox 22 too?

Yes, we should also land this in 22.
Flags: needinfo?(mratcliffe)
Verified as fixed also on Windows 7, 64 bits, with Firefox 22 beta 4, User agent Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0, Build ID: 20130605070403
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.