Some parts of click-to-play don't work if you disable doorhangers

RESOLVED FIXED in seamonkey2.20

Status

SeaMonkey
UI Design
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

Trunk
seamonkey2.20

SeaMonkey Tracking Flags

(seamonkey2.17 unaffected, seamonkey2.18 fixed, seamonkey2.19 fixed, seamonkey2.20 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Bug 807664 added code to the doorhanger-only section of notification.xml, and then bug 837399 compounded the issue by adding more code.
(Assignee)

Updated

4 years ago
status-seamonkey2.17: --- → unaffected
status-seamonkey2.18: --- → affected
status-seamonkey2.19: --- → affected
status-seamonkey2.20: --- → affected
(Assignee)

Comment 1

4 years ago
Created attachment 736029 [details] [diff] [review]
Proposed patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #736029 - Flags: review?(philip.chee)

Comment 2

4 years ago
Comment on attachment 736029 [details] [diff] [review]
Proposed patch

r=me
Attachment #736029 - Flags: review?(philip.chee) → review+
(Assignee)

Comment 3

4 years ago
Pushed comm-central changeset 0e185eec4ded.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-seamonkey2.20: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.20
(Assignee)

Comment 4

4 years ago
Comment on attachment 736029 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 807664
User impact if declined: Can't decline click-to-play without doorhangers
Testing completed (on m-c, etc.): Landed on c-c
Risk to taking this patch (and alternatives if risky): Low, mostly moved code
String changes made by this patch: None
Attachment #736029 - Flags: approval-comm-beta?
Attachment #736029 - Flags: approval-comm-aurora?

Updated

4 years ago
Attachment #736029 - Flags: approval-comm-beta?
Attachment #736029 - Flags: approval-comm-beta+
Attachment #736029 - Flags: approval-comm-aurora?
Attachment #736029 - Flags: approval-comm-aurora+
(Assignee)

Comment 5

4 years ago
https://hg.mozilla.org/releases/comm-aurora/rev/12ea7b098021
https://hg.mozilla.org/releases/comm-beta/rev/4a28b1a7bb7d
status-seamonkey2.18: affected → fixed
status-seamonkey2.19: affected → fixed
You need to log in before you can comment on or make changes to this bug.