Closed Bug 860578 Opened 7 years ago Closed 7 years ago

No favicons in Panorama view

Categories

(Firefox Graveyard :: Panorama, defect)

22 Branch
x86
macOS
defect
Not set

Tracking

(firefox22+ verified, firefox23+ verified)

RESOLVED FIXED
Firefox 23
Tracking Status
firefox22 + verified
firefox23 + verified

People

(Reporter: stesen-moz, Assigned: jfkthame)

References

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Attached image Screenshot of problem
In recent Nightly builds (I'm not sure when this first arose, I don't all too often have enough tabs open to warrant grouping), I have noticed that none of the thumbnails in Panorama view display favicons. The generic "dotted box" icon is shown instead for all normal and app tabs.

I have attached a screenshot to demonstrate.
Regression range:
m-c
good=2013-03-27
bad=2013-03-28
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=178a4a770bb1&tochange=962f5293f87f

Suspected bug:
Jonathan Kew — bug 828508 - use higher-res favicons for tab titles in hidpi mode if available. r=dao
Blocks: 828508
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Similar to bug 866444, we need to strip the -moz-resolution fragment from the favicon URI as stored in the tab's image attribute.
Attachment #744665 - Flags: review?(dao)
Assignee: nobody → jfkthame
Comment on attachment 744665 [details] [diff] [review]
fix missing favicons in Panorama view

Please use gBrowser.getIcon(tab).
Attachment #744665 - Flags: review?(dao) → review-
That doesn't work as well - it fails to get icons for restored-session tabs that have not actually been loaded, whereas reading the tab's image attribute does get them.
Comment on attachment 744665 [details] [diff] [review]
fix missing favicons in Panorama view

Re-requesting r? on this version of the patch, in view of comment #4.
Attachment #744665 - Flags: review- → review?(dao)
Attachment #744665 - Attachment is obsolete: true
Attachment #744665 - Flags: review?(dao)
Depends on: 866444
Attachment #746416 - Flags: review?(dao) → review+
Pushed this to inbound; the behavior for "pending" restored tabs will still be broken until bug 866444 lands, but aside from that it should fix the issue.

https://hg.mozilla.org/integration/mozilla-inbound/rev/f6525b901c95
Target Milestone: --- → Firefox 23
https://hg.mozilla.org/mozilla-central/rev/f6525b901c95
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 746416 [details] [diff] [review]
fix missing favicons in Panorama view

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 828508

User impact if declined: missing favicons in Panorama view

Testing completed (on m-c, etc.): in Nightly for a few days

Risk to taking this patch (and alternatives if risky): minimal - simple one-liner in tabview code, no effect elsewhere

String or IDL/UUID changes made by this patch: none
Attachment #746416 - Flags: approval-mozilla-aurora?
Comment on attachment 746416 [details] [diff] [review]
fix missing favicons in Panorama view

Moving approval request from aurora to beta, as FF22 has now merged to beta.
Attachment #746416 - Flags: approval-mozilla-aurora? → approval-mozilla-beta?
Attachment #746416 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified fixed with Firefox 22 beta 1 (build ID: 20130514181517) on Mac OSX 10.8.3 32bit mode.
QA Contact: manuela.muntean
Verified fixed with Firefox 23 beta 7 (build ID: 20130718163513) on Mac OSX 10.8.3 32bit mode.
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.