Closed Bug 860705 Opened 7 years ago Closed 4 years ago

[browserconsole] Do not display messages from open tabs (only show messages from chrome)

Categories

(DevTools :: Console, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1260877

People

(Reporter: msucan, Unassigned)

References

Details

Attachments

(1 file)

To lower the number the number of messages we get in the Browser Console we should look into how we can filter out all of the messages that belong to open tabs.
See bug 593540 for removing content messages from the Error Console.
(In reply to Jared Wein [:jaws] from comment #1)
> See bug 593540 for removing content messages from the Error Console.

Thank you!
Priority: -- → P3
Duplicate of this bug: 899989
Duplicate of this bug: 918665
Summary: [browserconsole] Do not display messages from open tabs → [browserconsole] Do not display messages from open tabs (only show messages from chrome)
Assignee: nobody → bmax1337
Status: NEW → ASSIGNED
Hey,

I think this solves the problem just am kind of stuck on writing the test. I'm not sure the best way to go about writing the test.
Attachment #8577697 - Flags: feedback?(jaws)
Comment on attachment 8577697 [details] [diff] [review]
Patch that fixes the bug, still need test.

Were you able to take a look at the patches on bug 593540? This also needs to account for about: and resource: URIs for example.
Attachment #8577697 - Flags: feedback?(jaws) → feedback+
Comment on attachment 8577697 [details] [diff] [review]
Patch that fixes the bug, still need test.

Review of attachment 8577697 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/webconsole/webconsole.js
@@ +1234,5 @@
>      let node = null;
>  
> +    // if this is an instance of browserconsole only show chrome messages.
> +    if (this.owner._browserConsole && sourceURL.substr(0,9) != "chrome://") {
> +      return null;

Have you checked if sourceURL can sometimes be missing? IIRC, I don't always see one in the console. If we need to use the scheme, it may be easier to blocklist https/http for the Browser Console. Since the scheme checking isn't going to be perfect, I think we may want it to be a pref in the Browser Console. Note that you can use .startsWith too
Where is messages from page in popup window?
AFAIK, I can not see the message in Web Console. It is only Browser Console.

So, I think this Bug should be wontfix.
Should this be marked as a dupe of bug 1260877?  Wasn't sure which way to dupe if so.
Flags: needinfo?(bgrinstead)
Assignee: bmax1337 → nobody
Status: ASSIGNED → NEW
(In reply to J. Ryan Stinnett [:jryans] (use ni?) from comment #9)
> Should this be marked as a dupe of bug 1260877?  Wasn't sure which way to
> dupe if so.

Yes I think we should dupe this to bug 1260877.  People have different preferences for this behvaior so that bug is about adding a UI to pick / filter.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(bgrinstead)
Resolution: --- → DUPLICATE
Duplicate of bug: 1260877
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.