Context menu Open Link in New Window broken in MailNews [gContextMenu.openLink is not a function]

RESOLVED FIXED in seamonkey2.20

Status

SeaMonkey
MailNews: General
--
major
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: InvisibleSmiley, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Trunk
seamonkey2.20
regression

SeaMonkey Tracking Flags

(seamonkey2.17 unaffected, seamonkey2.18? fixed, seamonkey2.19 fixed, seamonkey2.20 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
STR: Try "Open Link in New Window" from inside MailNews (e.g. the "SeaMonkey" link in the MailNews start page header)

Starting with 2.18b1, nothing happens (2.17 is fine).
The following appears on the Error Console:

Error: TypeError: gContextMenu.openLink is not a function
Source: chrome://messenger/content/messenger.xul
Line: 1

Neil, Ian, Philip, can you help track down the bug that caused this? I guess it was a suite-global change rather than one limited to MailNews. Maybe related to private browsing?

We shall get this fixed ASAP so we have time to verify and request branch approvals before 2.18 leaves the beta stage.
(Assignee)

Updated

4 years ago
Blocks: 841230
Keywords: regressionwindow-wanted
(Assignee)

Comment 1

4 years ago
Created attachment 736534 [details] [diff] [review]
Draft patch

Presumably at some point we'll want to open links from mail into private windows, but unfortunately the access key is used by Delete, so that won't work right now.
(Assignee)

Comment 2

4 years ago
Created attachment 736536 [details] [diff] [review]
Proposed patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #736536 - Flags: review?(philip.chee)
Attachment #736536 - Flags: review?(jh)
Attachment #736536 - Flags: review?(iann_bugzilla)

Updated

4 years ago
Attachment #736536 - Flags: review?(iann_bugzilla) → review+

Comment 3

4 years ago
Comment on attachment 736536 [details] [diff] [review]
Proposed patch

WFM r=me
Attachment #736536 - Flags: review?(philip.chee) → review+
(Reporter)

Updated

4 years ago
Attachment #736536 - Flags: review?(jh)
(Assignee)

Comment 4

4 years ago
Pushed comm-central changeset 9ba43addb8ab.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-seamonkey2.20: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.20
(Assignee)

Comment 5

4 years ago
Comment on attachment 736536 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 841230
User impact if declined: Menuitem does not work
Testing completed (on m-c, etc.): Landed on c-c
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #736536 - Flags: approval-comm-beta?
Attachment #736536 - Flags: approval-comm-aurora?

Updated

4 years ago
Attachment #736536 - Flags: approval-comm-beta?
Attachment #736536 - Flags: approval-comm-beta+
Attachment #736536 - Flags: approval-comm-aurora?
Attachment #736536 - Flags: approval-comm-aurora+
(Assignee)

Comment 6

4 years ago
https://hg.mozilla.org/releases/comm-aurora/rev/90d5ca3ecce6
https://hg.mozilla.org/releases/comm-beta/rev/aa541a194882
status-seamonkey2.18: affected → fixed
status-seamonkey2.19: affected → fixed
You need to log in before you can comment on or make changes to this bug.