Keyboard gets messed up in the URL bar/Mail address bar

VERIFIED DUPLICATE of bug 84804

Status

--
minor
VERIFIED DUPLICATE of bug 84804
18 years ago
14 years ago

People

(Reporter: fleona, Assigned: hewitt)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3-20mdk i686; en-US; rv:0.9.1+)
Gecko/20010613
BuildID:    2001061306

Sometimes when you are typing in the url bar the keyboard gets screwed up. The
first letter always shows up fine but all letters after it display with weird
characters, making the browser unusable

Reproducible: Sometimes
Steps to Reproduce:
1.Just type in the url bar


Actual Results:  Weird characters show up, and the only way to fix this is to
restart mozilla

Expected Results:  Normal typing

Enclosing an attachment for explanation
(Reporter)

Comment 1

18 years ago
Created attachment 38628 [details]
Screenshot of the alphabet screwed up in the url bar
(Reporter)

Comment 2

18 years ago
Using Xfree 4.0.3, one of those us keyboards from 1993 without the win key (it's
AST), kde 2.1.1, mandrake 8, keyboard set up this way:
XkbKeycodes     "xfree86"
    XkbTypes        "default"
    XkbCompat       "default"
    XkbSymbols      "us(pc105)"
    XkbGeometry     "pc"
    XkbRules        "xfree86"
    XkbModel        "pc105"
    XkbLayout       "us_intl"

Dont know that else to say. This has happened on all builds.

Comment 3

18 years ago
believe it or not, this is actually a dupe.
thanks for the X server information though, I think that will help
(Reporter)

Comment 4

18 years ago
Well, i have only been using mozilla since 0.9 so i guess tons of people should
have seen this before me
I dont think this is tied to my keyboard config, but what else can i do? I would
have reported this sooner but it does not happen that much

Comment 5

18 years ago
WFM Win98SE 200106504

Comment 6

18 years ago
I think it's some wierd combination of x servers, fonts, keyboard
configurations.. I still can't find the dupe however..I know it's there! :)
(Reporter)

Comment 7

18 years ago
I am using rpm mozilla-fonts on mandrake 8. The best looking fonts in any
browser in linux. I highly recommend them, using them with kde's/qt's/xfree's
antialiasing 
looks very sweet

Like i said, it's hard to reproduce
Jay Garcia, this is a linux bug, so there is no point in telling wfm on windows
(Reporter)

Comment 8

18 years ago
Update: bug happens on email too!
No longer an url bar component bug
Reasigning to browser-general for the moment...
Component: URL Bar → Browser-General
Summary: Keyboard gets messed up in the URL bar → Keyboard gets messed up in the URL bar/Mail address bar
(Reporter)

Comment 9

18 years ago
Created attachment 38724 [details]
Screenshot of the mail bar screwed up
(Reporter)

Comment 10

18 years ago
This is getting too frequent now >:-<
(Reporter)

Comment 11

18 years ago
Does somebody know how to run mozilla in gdb?
/usr/local/mozilla/mozilla is not recognized by gdb, and mozilla-bin wont
execute directly without running the mozilla one
(Reporter)

Comment 12

18 years ago
I pressed my right alt key when i saw this problem in the url bar, and it got
fixed! Pressing the alt key again would not make the bug reappear, but pressing
the ` key did make the bug reappear!

That's why few people cant reproduce... I use the ` key with the shift key in
order to do the Ññ keys!

Reducing severity to minor because i found an easy workaround

Now this should be very easy to fix

Severity: major → minor

Comment 13

18 years ago
./mozilla -g

Comment 14

18 years ago
oh right, please don't randomly assign to B-G, it's likely to get poor bugs 
lost.  URL Bar is usually good enough for most autocomplete bugs, but we do in 
fact have a component for autocomplete itself
Assignee: alecf → hewitt
Component: Browser-General → XP Apps: Autocomplete
QA Contact: claudius → blake
(Reporter)

Comment 15

18 years ago
I assigned to url bar because i found  the bug in the url bar, but then found
out that mail was having the same problem. So, it's a general problem to me. But
you are the coders, and you know better where the bug goes

At least you have the exact test case, it should not be hard to fix

Comment 16

18 years ago
a workaround is detailed (change a pref) in the dupe bug 84804.

*** This bug has been marked as a duplicate of 84804 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 17

18 years ago
verified dup
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.