Launching the Settings app while SIM locked should NOT display the SIM PIN dialog

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mihai, Assigned: mihai)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18+ verified, b2g18-v1.0.1 verified)

Details

Attachments

(1 attachment)

This bug is a follow-up to Bug 846574 which highlighted the wrong behavior of the SIM PIN dialog for the Settings app (see Bug 846574 comment 8).

Steps to reproduce:
1. Unlock the lock screen, entering the unlock code if necessary.
2. At the SIM PIN entry page, tap the X in the upper left corner to cancel entering the PIN.
3. Go to the Settings app

Expected:
The Settings App should launch without prompting for SIM PIN entry.

Actual:
The SIM PIN entry page appears, prompting the user to enter the code.
(Assignee)

Updated

5 years ago
tracking-b2g18: --- → ?
status-b2g18: --- → affected
tracking-b2g18: ? → +
Created attachment 737584 [details]
Pull Request #9186 - Don't prompt for SIM PIN entry when Settings app is opened

I'm not sure if this is the best approach to check if the app dispatching 'appwillopen' event is the Settings app, however, it seems quite unlikely that there will be any other app with 'telephony' or 'sms' permissions whose name is 'Settings' (in the manifest).
Attachment #737584 - Flags: review?(etienne)
Comment on attachment 737584 [details]
Pull Request #9186 - Don't prompt for SIM PIN entry when Settings app is opened

Let's do it with |app.manifestURL|, should be safer :)
Attachment #737584 - Flags: review?(etienne)
Comment on attachment 737584 [details]
Pull Request #9186 - Don't prompt for SIM PIN entry when Settings app is opened

Thanks for the feedback, Etienne! I updated the patch, if everything looks fine, feel free to merge it to master -- I already added the r=you flag :)
Attachment #737584 - Flags: review?(etienne)
Comment on attachment 737584 [details]
Pull Request #9186 - Don't prompt for SIM PIN entry when Settings app is opened

Thanks
Attachment #737584 - Flags: review?(etienne) → review+
https://github.com/mozilla-b2g/gaia/commit/9944dd8671c305a0be62d9cef918e022e5184ac0
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 737584 [details]
Pull Request #9186 - Don't prompt for SIM PIN entry when Settings app is opened

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): SIM PIN dialog > Settings App
User impact if declined: Low (UX recommended to not show the dialog when opening the Settings app)
Testing completed: Yes
Risk to taking this patch (and alternatives if risky): None/Low
String or UUID changes made by this patch: No
Attachment #737584 - Flags: approval-gaia-v1?

Updated

5 years ago
blocking-b2g: --- → tef+
status-b2g18-v1.0.1: --- → affected
Comment on attachment 737584 [details]
Pull Request #9186 - Don't prompt for SIM PIN entry when Settings app is opened

This is tef+ and won't require approval-gaia-v1
Attachment #737584 - Flags: approval-gaia-v1?
v1-train: 58eecbaf6404be9229ad0c9d2fd76646b2ccf5d9
v1.0.1: 04039d59c83864ff2cb41bdd8b165d59ad0e80c7
status-b2g18: affected → fixed
status-b2g18-v1.0.1: affected → fixed

Comment 9

5 years ago
Verified fixed the ability to go to the Settings App without prompting for SIM PIN entry as specified by the steps in the Description.

Tested on the following:

Environmental  Variables:
Inari Build ID: 20130502070201
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/5c1d67e0c242
Gaia: 11477c127ae9be5051e4cfbcbf3da1d4150f9967

and on:

Environmental  Variables:
Unagi Build ID: 20130503070204
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8becaf2a0bc7
Gaia: b0aca0dd1e2955e11190ede725e1fb9ee596438b
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified
status-b2g18-v1.0.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.