Bug 861235 (input-type-docs)

[meta] Clean up the <input> doc (<input type="..."> etc)

RESOLVED FIXED

Status

P5
normal
RESOLVED FIXED
6 years ago
a year ago

People

(Reporter: sheppy, Unassigned, Mentored)

Tracking

Details

(URL)

(Reporter)

Description

6 years ago
:: Developer Documentation Request

      Request Type: Correction
     Gecko Version: unspecified
 Technical Contact: 

:: Details

The documentation for the <input> element is incredibly messy. We need to present this information more cleanly.
The first step is to create one sub-page for each type named <input type="xyz"> with slug /en-US/docs/Web/HTML/Element/Input/Xyz.
The second step is to complete our documentations of these using the ddn that we have about these.
The third step is to clear the first page to lead to the subpages.

If anybody want to do this, I'm happy to help him/her. It is not very complicated but it is a significant amount of work (~40 hours).

Comment 2

3 years ago
You want to create individual page for type Password too?
Flags: needinfo?(eshepherd)
Yes, we do. Do you want to do it? I'll create a bug for it straight away.
Assignee: jypenator → nobody
Flags: needinfo?(eshepherd)
Summary: Clean up the <input> doc → [meta] Clean up the <input> doc

Comment 4

3 years ago
yes I will create that can you please create
Depends on: 1243347

Comment 5

3 years ago
Thanks
Flags: needinfo?(eshepherd)
The <input type="password"> page[1] was obviously already created last year and was revised a few times in the meantime.
So I remove the needinfo flag for Sheppy.

Currently, the following subpages are still missing:

- <input type="date">
- <input type="datetime-local">
- <input type="email">
- <input type="file">
- <input type="hidden">
- <input type="month">
- <input type="number">
- <input type="radio">
- <input type="range">
- <input type="reset">
- <input type="search">
- <input type="submit">
- <input type="tel">
- <input type="text">
- <input type="time">
- <input type="url">
- <input type="week">

I've linked them from the main <input> page already.

Sebastian
Mentor: jypenator, sebastianzartner
Flags: needinfo?(eshepherd)
Depends on: 866457, 866440, 866430
(Reporter)

Updated

a year ago
Summary: [meta] Clean up the <input> doc → [meta] Clean up the <input> doc (<input type="..."> etc)
(Reporter)

Updated

a year ago
Duplicate of this bug: 1372713
(Reporter)

Updated

a year ago
Alias: input-type-docs
(Reporter)

Updated

a year ago
Depends on: 1298625
(Reporter)

Updated

a year ago
Depends on: 1343246
(Reporter)

Updated

a year ago
Depends on: 1347702
(Reporter)

Updated

a year ago
Depends on: 1352504
(Reporter)

Updated

a year ago
Depends on: 1349526
(Reporter)

Updated

a year ago
Depends on: 1355491
(Reporter)

Updated

a year ago
Depends on: 1371265
(Reporter)

Updated

a year ago
Depends on: 1368863
All of the input types got documented, https://developer.mozilla.org/en-US/docs/Web/HTML/Element/input#Form_%3Cinput%3E_types
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.