Closed Bug 861301 Opened 8 years ago Closed 8 years ago

When in privacy mode in Firefox 20, links from other places always open a new window instead of a tab

Categories

(Firefox :: Private Browsing, defect)

20 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 843247

People

(Reporter: cjashfor, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130401133302

Steps to reproduce:

I clicked on a URL in an email in Thunderbird, while Firefox is in privacy mode.


Actual results:

It opened up a new Firefox window.


Expected results:

It should have opened a tab in the existing Firefox window.

This problem occurs only when in privacy mode.   If I turn off privacy mode, links open in new tabs, as desired.
Could you please try the following, to see if you still reproduce this issue :

1) try this with a clean profile: http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

2) running in Safe mode: http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Component: Untriaged → Private Browsing
Corey, are you using the "Never remember history" mode, or do you simply only have private windows open?
Flags: needinfo?(cjashfor)
Josh:  I was using the "Never remember history" mode.  Actually, I don't know how to open private windows individually, so no I wasn't doing that.

Manuela: I'll see if I can try that later today.
Flags: needinfo?(cjashfor)
Huh, from what you describe, bug 843247 should have fixed this problem. I wonder if that regressed somehow?
I confirm the bug is present using Firefox 20.0 in Fedora GNU/Linux 18 x86_64.

I created a new profile by deleting my current one.

The bug appears as soon as I activate the "Never remember history" mode.

The bug still occurs in SafeMode.
Corey, could you test a nightly build and see if you see the problem there? http://nightly.mozilla.org/ . If it is not present, could you also check builds from http://aurora.mozilla.org/ and http://beta.mozilla.org/ ?
Flags: needinfo?(cjashfor)
I am using the nightly build to add this comment.  The problem reported in this bugzilla does _not_ appear in the Nightly build, but I do notice that the little purple mask that indicates privacy mode has gone away.  
I don't know if that was an intended change or not.
Flags: needinfo?(cjashfor)
OK, now I'm using Aurora in privacy mode.  The bug does not reproduce.  (purple mask gone in this release as well)
Now I'm using Beta in privacy mode.  The bug does not reproduce.  (again purple mask is gone)

I should mention that both Aurora and Beta seemed only to be available in 32-bit variants, but it seems unlikely that it would make a difference.  I did use the x86_64 variant of Nightly, though.
So it seems like bug 843247 was never fixed on 20?  Not sure how that's possible, Josh?

Corey, thanks a lot for your help here.  The removal of the mask icon is intentional, since we don't want to constantly remember users that they're in private mode if they've asked to always be in that mode.  And I don't believe that there is any difference between 32-bit and 64-bit builds with regards to this.
Flags: needinfo?(josh)
No clue. It looks like it was verified quite thoroughly :/
Flags: needinfo?(josh)
Well, there's unfortunately not much that we can do for 20.  Otherwise, this is a dupe of bug 843247.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 843247
According to that bug, it was fixed only in 21 and beyond.  So it doesn't appear there's any mystery here.  I'm glad to see it's fixed in 21; I hope 21 goes live soon so that Fedora will pick it up.
You need to log in before you can comment on or make changes to this bug.