Hyperlinks from other applications only open in new window when using private browsing (instead of in a new tab)

RESOLVED FIXED in Firefox 20

Status

()

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: forticulous, Assigned: jdm)

Tracking

({regression})

20 Branch
Firefox 22
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox20+ verified, firefox21+ verified, firefox22 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:20.0) Gecko/20130219 Firefox/20.0
Build ID: 20130219042021

Steps to reproduce:

Using Aurora 20.0a2 (2013-02-19)
I clicked a hyperlink in email or messenger client


Actual results:

The link opened in a new aurora window


Expected results:

It should have opened in a new tab, as all my preferences are set that way.

Also, I have noticed the issue only happens when I am using private browsing mode.

Updated

6 years ago
Blocks: 463027
Component: Untriaged → Private Browsing

Updated

6 years ago
Duplicate of this bug: 844720

Updated

6 years ago
Summary: Hyperlinks only open in new window when using private browsing → Hyperlinks from other applications only open in new window when using private browsing (instead of in a new tab)
(Assignee)

Comment 2

6 years ago
Can you provide a page that reproduces this behaviour for you?
Flags: needinfo?(forticulous)
(Reporter)

Comment 3

6 years ago
Any URL will do.
To reproduce, make sure settings are set to open new windows in a new tab instead and turn private browsing on, then click a link in an email or something.  It ignores the settings and open in a new window.

Then try it again without private browsing and it will open in a new tab as expected.
Flags: needinfo?(forticulous)
(Assignee)

Comment 4

6 years ago
A URL that demonstrates this problem for you would help us ensure that we're performing the same tests that you are.
Flags: needinfo?(forticulous)
(Assignee)

Comment 5

6 years ago
For example, despite my test page at http://joshmatthews.net/newtab.html opening a new window with the "Open new windows as tabs" setting disabled, I do not see the problem you describe with it enabled in private browsing mode in nightly builds.
(Reporter)

Comment 6

6 years ago
I was just using http://www.google.com.  Just to clarify, I'm talking about clicking a link in an external application in my case Fraise which is just a text editor.
It's also possible the issue has been fixed in the nightly build as I'm using the Aurora update channel.
Flags: needinfo?(forticulous)
(Assignee)

Comment 7

6 years ago
Ok, can you be more explicit about the windows you have open when you see this problem? To be clear, external links will never open in a private window. If no non-private window exists, I would expect a new one to be spawned.
(Assignee)

Comment 8

6 years ago
Also, my apologies: I apparently skimmed over both the title of the bug and your first comment, because you made it pretty clear that the problem was with links being opened from other applications. I'll work on my reading comprehension skills in the future.
(Reporter)

Comment 9

6 years ago
Hmm. I've been using private browsing as the default for awhile now, but never noticed external links opening in new windows until the last month or so.  But if that's the behavior that's always been there that's just the way it is I guess.
(Assignee)

Comment 10

6 years ago
Do you mean that you're running in permanent private browsing mode (ie. Settings -> Privacy -> Never Remember History)?
(Reporter)

Comment 11

6 years ago
Yeah actually that is correct.  Also the issue doesn't happen if I have it set to Settings -> Privacy -> Remember History
(Assignee)

Comment 12

6 years ago
This is a legitimate oddity you've pointed out. I think we'll special-case perma-private mode when opening external links to make the experience more pleasant. Thanks for raising the issue!
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

6 years ago
Assignee: nobody → josh
status-firefox20: --- → affected
status-firefox21: --- → affected
status-firefox22: --- → affected
tracking-firefox20: --- → ?
(Reporter)

Comment 13

6 years ago
Thank you!
(Assignee)

Comment 14

6 years ago
Created attachment 718638 [details] [diff] [review]
Allow external links to be opened in private windows in perma-private mode.
Attachment #718638 - Flags: review?(ehsan)

Updated

6 years ago
Attachment #718638 - Flags: review?(ehsan) → review+
https://hg.mozilla.org/mozilla-central/rev/4454f18d71bf
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22

Updated

6 years ago
status-firefox22: affected → fixed
tracking-firefox20: ? → +
tracking-firefox21: --- → +
Keywords: regression
(Assignee)

Comment 17

6 years ago
Comment on attachment 718638 [details] [diff] [review]
Allow external links to be opened in private windows in perma-private mode.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 829180 
User impact if declined: Links from external applications will always open in new windows when using permanent private browsing mode.
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None
Attachment #718638 - Flags: approval-mozilla-beta?
Attachment #718638 - Flags: approval-mozilla-aurora?
Comment on attachment 718638 [details] [diff] [review]
Allow external links to be opened in private windows in perma-private mode.

Please make sure to land before 3/5(tomorrow) to make sure this gets into FX20 beta 3.
Attachment #718638 - Flags: approval-mozilla-beta?
Attachment #718638 - Flags: approval-mozilla-beta+
Attachment #718638 - Flags: approval-mozilla-aurora?
Attachment #718638 - Flags: approval-mozilla-aurora+
Keywords: qawanted, verifyme
QA Contact: jbecerra
(Assignee)

Updated

6 years ago
status-firefox20: affected → fixed
status-firefox21: affected → fixed
External links are opened in new tabs instead of new windows in perma-private mode.
Verified fixed FF 20b3 Win 7, Ubuntu 12.04 and Mac OS X 10.8.2.
status-firefox20: fixed → verified
Keywords: qawanted
Verified fixed on Firefox Aurora 22.0a2 – 20130407004016: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20130407 Firefox/22.0


Verified fixed on Firefox 21 beta 1 - 20130401192816: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20100101 Firefox/21.0
status-firefox21: fixed → verified
status-firefox22: fixed → verified

Updated

6 years ago
Duplicate of this bug: 861301
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.