Closed Bug 861735 Opened 10 years ago Closed 10 years ago

[Meta] Kill off mouse_event_shim.js

Categories

(Firefox OS Graveyard :: Gaia, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jwatt, Assigned: mahsam.29)

References

Details

(Keywords: perf, Whiteboard: [c= p= s=2013.09.06 u=])

Seems to me that mouse_event_shim.js should die in favor of gecko dispatched events. I don't see a bug for that, so filing this one.

djf, what are the various things that need to happen in order to resolve this bug? Would you be able to file bugs blocking this one for (some of?) those various pieces so we can get started?
Thanks for filing this bug, Jonathan.  I just went to file one myself and found that it already existed here.

Most of the remaining uses of this shim are in the Media apps. I'll try to get this bug listed in the Media team's backlog and hopefully fix it for v1.2.
To understand this bug, you've got to know some history.

It used to be that FirefoxOS sent touch events and mouse events. So we used mouse events in our apps so that they would also run unmodified on the desktop.

The problem is that all other mobile platforms follow mobile safari and send only touch events plus the click event.  So at the very last minute, we switched FirefoxOS to follow this defacto standard.

mouse_event_shim.js is what allowed us to get away with this.  Any apps that need to do things like follow drags (think media sliders) used this shim to translate touch events into mouse motion events.

Now it is time to get rid of the shim and port the apps to use touch events.

Note that we still want the apps to be able to run in Nightly, however.  I don't know what is required to make that happen.  I think there is something automatic that will make touch events just work on the desktop, but I'm not actually sure about that, so you'll probably need to figure that out first.
Assignee: nobody → mmojtahedi
Hi Mahsa - Any progress here? There seems like there might be a lot of work for this one bug involved.

If you'd like help, I think the best thing to do would be to turn this into a meta bug and open a blocking bug for each app which we need to remove the shim from.
Flags: needinfo?(mmojtahedi)
Hi Kevin, my progress speeds up soon since I received a phone and I'm setting it up to test my changes. Basically how I'm fixing this bug is: find the apps which use the shim, remove the shim from them, test the app on desktop and device.

I agree that removing shim from some apps need more work than I expected. I'm not sure what meta bug is, but breaking down this bug for each app might not be a bad idea.
Flags: needinfo?(mmojtahedi)
IMHO, is it nice to make this bug as a meta bug, and open bugs for each app??
Depends on: 893269
No longer depends on: 896415
Summary: Kill off mouse_event_shim.js → [Meta] Kill off mouse_event_shim.js
Depends on: 901578
Depends on: 901587
Keywords: perf
Whiteboard: [c= p=]
Depends on: 906750
Thanks everyone who worked on getting rid of this!
All bugs closed. Thanks to everyone involved and the great reviewers!
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Whiteboard: [c= p=] → [c= p= s=2013.09.06 u=]
You need to log in before you can comment on or make changes to this bug.