Closed Bug 861943 Opened 8 years ago Closed 8 years ago

Unable to copy URL from fennec on awesomescreen

Categories

(Firefox for Android Graveyard :: General, defect)

22 Branch
All
Android
defect
Not set
normal

Tracking

(firefox21 unaffected, firefox22 fixed, firefox23 unaffected, firefox24 unaffected, fennec22+)

RESOLVED FIXED
Tracking Status
firefox21 --- unaffected
firefox22 --- fixed
firefox23 --- unaffected
firefox24 --- unaffected
fennec 22+ ---

People

(Reporter: kats, Assigned: jchen)

References

Details

(Keywords: regression)

1. Start Fennec
2. Load a page, e.g. http://people.mozilla.com/~kgupta/bug/748495.html
3. Tap on the awesome bar to open the awesome screen. Note that the URL is fully selected, and that long-pressing on the URL field just brings up a "PASTE" context item (this is expected behaviour)
4. Tap once on the URL bar to remove the selection from the URL but leave the focus on the URL field
5. Long press on the URL bar

Expected results:
- The entire URL is selected and the action bar icons can be used to copy the URL

Actual results:
- One "word" of the URL is selected (in my case I long-pressed on kgupta and that is what got selected) and selecting the copy icon only copies that part of the URL. There doesn't appear to be any way to select the entire URL for copy.

This is a regression; in older Fennecs the "expected results" were what happened.
I can confirm this is a regression. I'm seeing this problem on Aurora (22), but not Beta (21). Not sure what would cause this regression, though.
tracking-fennec: --- → ?
tracking-fennec: ? → 22+
need info to kevin to get the regression range
Assignee: nobody → margaret.leibovic
Flags: needinfo?(kbrosnan)
Kevin, are you working on getting a regression range on this?

Also, this seems like an IME issue, maybe cpeterson wants to help take a look :)
Adrian, can you help find a regression-range? Kevin is PTO.
Flags: needinfo?(kbrosnan) → needinfo?(adrian.tamas)
This is no longer reproducible on the latest builds of 23 (aurora) and 24 (nightly). I can still repro it on 22.0b3 though.
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #5)
> This is no longer reproducible on the latest builds of 23 (aurora) and 24
> (nightly). I can still repro it on 22.0b3 though.

So what would really be nice is a regression range that shows what fixed this in 23.
We will get a regression-range(fix-range) first thing tomorrow morning
good build: 22.04.2013 
bad build:  21.04.2013 

pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0d50cb959c46&tochange=50d25e083421
The tinderbox inbound builds are missing since the issue is older than one month.
Flags: needinfo?(adrian.tamas)
(In reply to Teodora Vermesan (:TeoVermesan) from comment #8)
> good build: 22.04.2013 
> bad build:  21.04.2013 
> 
> pushlog:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=0d50cb959c46&tochange=50d25e083421
> The tinderbox inbound builds are missing since the issue is older than one
> month.

That means http://hg.mozilla.org/mozilla-central/rev/6953e922b5c7 actually fixed the issue, right? If so, we can uplift Bug 862069 and Bug 860158 to Beta.
Assignee: margaret.leibovic → nchen
Confirmed locally that uplifting those two bugs would fix this issue. Going to update the patches and request uplifting in those bugs.
Depends on: 862069, 860158
Uplifted to beta
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Version: unspecified → Firefox 22
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.