Images not saving into clipboard using "Copy Image" while website is loading

RESOLVED INCOMPLETE

Status

Firefox for Metro
Input
RESOLVED INCOMPLETE
5 years ago
9 months ago

People

(Reporter: kjozwiak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [defect] p=0)

(Reporter)

Description

5 years ago
When selecting "Copy Image" from the image context menu while the webpage is loading, the image will not be saved into the clipboard. If you do the same thing once the website has been fully loaded, the image will be saved into the clipboard without issues.

Steps to reproduce the issue:

1) Open Firefox Metro
2) Go to http://browse.deviantart.com
3) Click on any image (this will take you to a page with a bigger image)
4) While the webpage is loading, tap and hold on the image and select "Copy Image"
5) Try pasting the image into "mspaint" and you will notice the image has not been added into the clipboard
6) If you repeat the same steps 1-5 and wait for the entire webpage to load, the image will be saved into the clipboard without issues

Current Behavior:

- When a website is being loaded, images will not be saved into the clipboard when selecting "Copy Image" from the image context menu

Expected Behavior:

- If the image is already loaded without the rest of the site being fully loaded, the image should still be saved into the clipboard
Does this happen with Desktop Firefox as well?
(Reporter)

Comment 2

5 years ago
Tried it on two different computers and couldn't reproduce the problem in the Firefox Desktop, but reproduced it on two different machines in Firefox Metro.

Also tried using shortcuts to make sure I copy the image before the webpage loads while using Firefox Desktop but could always copy the image into the clipboard.
OK, thanks for checking!
I think this can wait until v2
Flags: needinfo?(asa)

Comment 5

5 years ago
Yeah. This isn't anything we should worry about for v1.
Flags: needinfo?(asa)
Priority: -- → P5

Updated

5 years ago
Blocks: 861683
No longer blocks: 859003, 833165

Updated

5 years ago
Priority: P5 → --

Updated

5 years ago
Blocks: 861680

Updated

5 years ago
No longer blocks: 861683

Updated

5 years ago
Summary: Defect: Images not saving into clipboard using "Copy Image" while website is loading → Images not saving into clipboard using "Copy Image" while website is loading
Whiteboard: feature=defect c=context_menus u=metro_firefox_user p=0 → [defect] p=0
(Assignee)

Updated

4 years ago
OS: Windows 8 Metro → Windows 8.1
Mass close of bugs in obsolete product https://bugzilla.mozilla.org/show_bug.cgi?id=1350354
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.