Closed Bug 862225 Opened 7 years ago Closed 7 years ago

Seed value 514 produces squares in SVG feTurbulence

Categories

(Core :: SVG, defect)

20 Branch
x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1122761

People

(Reporter: ryan.richards, Unassigned)

References

Details

Attachments

(2 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

I opened http://アニメイヘム.com/binder/card0000514.svg in Firefox while troubleshooting the same bug in Apache Batik.


Actual results:

Large squares appeared in the 'background' of the image.


Expected results:

It should have been smooth.
Component: Untriaged → SVG
Product: Firefox → Core
These other seeds between 0 and 9999 are affected: 1977, 2337, 4777, 8032, and 9615.
ASV, Chrome, Firefox and Batik have independently written implementations. They are all the same so I'm going to conclude they are all correct.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
(In reply to Robert Longson from comment #2)
> ASV, Chrome, Firefox and Batik have independently written implementations.
> They are all the same so I'm going to conclude they are all correct.

Displays as expected in Opera.
Just feTurbulence in the filter, no other effects.
Attachment #737845 - Attachment is obsolete: true
(In reply to Ryan Richards from comment #3)
> (In reply to Robert Longson from comment #2)
> > ASV, Chrome, Firefox and Batik have independently written implementations.
> > They are all the same so I'm going to conclude they are all correct.
> 
> Displays as expected in Opera.

So Opera is the odd one out. That suggests it's wrong.
Adding this to the filter makes Firefox the odd one out.
<feComponentTransfer>
<feFuncA type="table" tableValues="1 1"/>
</feComponentTransfer>
The specification is changing so this is no longer invalid, we're changing to match.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 1122761
You need to log in before you can comment on or make changes to this bug.