Changing the dir with javascript does not work.

RESOLVED FIXED

Status

()

Core
Layout: Text
RESOLVED FIXED
17 years ago
10 years ago

People

(Reporter: José Jeria, Assigned: mkaply)

Tracking

({regression})

Trunk
x86
Windows 2000
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.1+)
Gecko/20010615
BuildID:    2001061520

onMouseOver="this.dir='rtl';" does not work as expected.

Reproducible: Always
Steps to Reproduce:
1. Run code
2. MouseOver the gray box
3. Nothing happends

Expected Results:  Expected the word "bug" to move to the right. And back when
the mouse leaves the box.

This works fine in Netscape 6.01

<TABLE BGCOLOR="#dcdccc" WIDTH="300" onMouseOver="this.dir='rtl';"
onMouseOut="this.dir='ltr';">
<TR>
	<TD>
	Bug
	</TD>
</TR>
</TABLE>

Comment 1

17 years ago
You mean Netscape 6.1, right?
(Reporter)

Comment 2

17 years ago
No, I mean Netscape 6.01. Works as expected in 6.01. Not working on the nightly 
builds.
The value does change in the DOM, which means that the correct information is
stored in the content model, but we're not correctly showing it, over to layout.
Assignee: jst → karnaze
Component: DOM Other → Layout
QA Contact: gerardok → petersen

Comment 4

17 years ago
Created attachment 43854 [details]
testcase

Comment 5

17 years ago
this should go to BiDi
Assignee: karnaze → mkaply
Status: UNCONFIRMED → NEW
Component: Layout → BiDi Hebrew & Arabic
Ever confirmed: true
QA Contact: petersen → giladehven
(Reporter)

Comment 6

17 years ago
Not that  I understand this to 100%, but how can this bug be "BiDi Hebrew &
Arabic"??
Shouldn't this be display?

Comment 7

17 years ago
Mass-move all BiDi Hebrew and Arabic qa to me, zach@zachlipton.com. 
Thank you Gilad for your service to this component, and best of luck to you 
in the future.

Sholom. 
QA Contact: giladehven → zach
(Reporter)

Updated

17 years ago
Keywords: regression
(Assignee)

Comment 8

17 years ago
Simon, do you have any idea where the code in layout that changes 
directionality us?

I'm not convinced this is a Bidi problem, as dir=rtl should work regardless of 
language.

did we put in any new code to work with this?

Mike Kaply
IBM
If the direction changes in the DOM but isn't reflected in rendering, this is
presumably an invalidation/reflow issue. 

Playing with the testcase, it seems that the |onMouseOver| works on the <td> but
not on the <table>, am I right?

cmanske, is this your beat?

Comment 10

17 years ago
Nope, not in my court!
(Reporter)

Comment 11

17 years ago
So... if not BiDi Hebrew & Arabic(!??), what then?
This seems to have been fixed, maybe by bug 103266? Marking WORKSFORME after
testing today's build on W2K and Linux.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 13

17 years ago
Created attachment 58348 [details]
Testcase showing that bug is not fixed?

See this new attachment. Nothing happends. Dont know if it is this bug that is
not fixed or if it is bug 103533 causing this.
(Reporter)

Comment 14

17 years ago
Created attachment 58349 [details]
new working testcase

Same as testase 58348, but now it works. What i changed was the script. 
obj.dir = (obj.dir=="Ltr")? "rtl":"ltr";
Now i check for "Ltr" instead of "ltr". Why is it so? Why capital L? Bug?
(Reporter)

Comment 15

17 years ago
I guess this one has to be reopened because it is not working as expected. See
comment 14. 
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
According to dbaron in http://bugzilla.mozilla.org/show_bug.cgi?id=10173#c6,
this behaviour is perfectly correct according to the DOM standard.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Updated

17 years ago
Blocks: 115713

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.