If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Local Video is upside down on Android when in portrait mode

VERIFIED FIXED in Firefox 23

Status

()

Core
WebRTC: Audio/Video
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: standard8, Assigned: gcp)

Tracking

(Blocks: 1 bug)

Trunk
mozilla24
All
Android
Points:
---

Firefox Tracking Flags

(firefox23+ fixed, firefox24 verified)

Details

(Whiteboard: [getUserMedia][android-gum+][blocking-gum-])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Using the demo at https://webrtc-demo.vcap.mozillalabs.com/ when in a video call, the video for the Android device is displayed upside down on both the Android and the Desktop display.

Tested on a Nexus 4.

Updated

5 years ago
Duplicate of this bug: 862815
(Assignee)

Comment 2

5 years ago
I think this is only for the back cam, but with permissions disabled you can't choose any other :P
Sounds like a cut and dry blocker for gUM on Android.
Whiteboard: [getUserMedia][android-gum+]
STR :: https://simpl.info/getusermedia/

--
Nightly (04/17) w/related prefs enabled
LG Nexus 4 (Android 4.2.2)
(Assignee)

Comment 5

5 years ago
FWIW, for these kind of bugs it's going to be really helpful to check whether the bug exists on multiple devices. Also, the subject implies this is only true in portait mode. Is it?
(Assignee)

Comment 6

5 years ago
>Also, the subject implies this is only true in portait mode. Is it?

Well darn, it is. That's...not what I would have expected.
Whiteboard: [getUserMedia][android-gum+] → [getUserMedia][android-gum+][blocking-gum-]
(Assignee)

Updated

5 years ago
Blocks: 750010
(Assignee)

Comment 7

4 years ago
Created attachment 751668 [details] [diff] [review]
Patch 1. Fix rotation amount calculation

The "compensate the mirror" thing came from the Android docs:
http://developer.android.com/reference/android/hardware/Camera.html#setDisplayOrientation%28int%29
"So the users can see themselves as looking into a mirror."

However, we don't use setDisplayOrientation and show the image that is actually sent to the remote, which doesn't use "mirror" orientation (wtf would you want *that* anyway?).

Tested this on a Nexus 4 to give the correct result in all orientations/cameras.
Attachment #751668 - Flags: review?(rjesup)

Updated

4 years ago
Attachment #751668 - Flags: review?(rjesup) → review+
(Assignee)

Comment 8

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/ff3cfa9675fd
https://hg.mozilla.org/mozilla-central/rev/ff3cfa9675fd
Assignee: nobody → gpascutto
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24

Updated

4 years ago
Keywords: verifyme
QA Contact: jsmith
(Assignee)

Comment 10

4 years ago
Comment on attachment 751668 [details] [diff] [review]
Patch 1. Fix rotation amount calculation

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 750010 and friends
User impact if declined: Stiff neck.
Testing completed (on m-c, etc.): Landed on m-c a few days ago.
Risk to taking this patch (and alternatives if risky): Little risk, change in preffed-off feature.
Attachment #751668 - Flags: approval-mozilla-aurora?

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-firefox24: --- → verified
Keywords: verifyme
status-firefox23: --- → affected
tracking-firefox23: --- → +
Attachment #751668 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 11

4 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/7c08df3249f9

Updated

4 years ago
status-firefox23: affected → fixed
You need to log in before you can comment on or make changes to this bug.