Closed Bug 863078 Opened 9 years ago Closed 3 years ago

Wrong line highlighted in the source editor when paused on a debugger statement

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 771490

People

(Reporter: vporof, Unassigned)

References

(Depends on 1 open bug)

Details

STR:

1. Go to http://jsbin.com/upejic/4/edit
2. Open debugger
3. Click me

Highlighted line is "<!--[if gte IE 8 ]><body class="source ie"><![endif]-->".

Granted, this is quite an edge and tricky case since the code is generated (line 358 is where things start to look familiar), but it's a bit confusing pausing on line 13 instead.
Assignee: nobody → past
Priority: -- → P2
The problem stems from the fact that in this case the script that contains the debugger statement is inside an iframe, which SpiderMonkey happily reports with the same URL as the outer window. Debugger.Source can't come soon enough...
Assignee: past → nobody
Depends on: 637572
Priority: P2 → P3
Depends on: dbg-source
Depends on: 784112
Duplicate of this bug: 1101271
Product: Firefox → DevTools

closing as this is for the old debugger.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 771490
You need to log in before you can comment on or make changes to this bug.