Closed Bug 863165 Opened 7 years ago Closed 7 years ago

Wrong time format display for calendar new event view[spanish]

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, firefox24 fixed, b2g18 verified, b2g18-v1.0.1 wontfix)

RESOLVED FIXED
1.1 QE2 (6jun)
blocking-b2g leo+
Tracking Status
firefox24 --- fixed
b2g18 --- verified
b2g18-v1.0.1 --- wontfix

People

(Reporter: leo.bugzilla.gaia, Assigned: gerard-majax)

References

Details

(Whiteboard: [TD-10834])

Attachments

(5 files, 1 obsolete file)

Precondition: Please use spanish as the default language.
Test Action: 
  1. Go to new event creation view.
Symptom:
  The format for date is YYYY-MM-DD.
Expected:
  The format of date should be DD-MM-YYYY.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 862278
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: DUPLICATE → ---
The time format displayed in system settings and calendar add-event view doesn't go together. In settings view, the time format tends to change w.r.t the applied locale. But, this is not the case with calendar.

The date format used in calendar is YYYY-MM-DD. The default date format for Spanish locale is DD-MM-YYYY. 

I would suggest the date format should be based on the applied locale.

Please let know your comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jsmith)
Makes sense to me.
Flags: needinfo?(jsmith)
blocking-b2g: --- → leo?
Triage - block for inconsistent presentation and regional requirements.
blocking-b2g: leo? → leo+
Whiteboard: [TD]10834
I suspect it might come from the exportDate method in js/utils/input_parser.js of Calendar app.
In fact I also have the issue in french locale :)
Assignee: nobody → lissyx+mozillians
Whiteboard: [TD]10834 → [TD-10834]
Target Milestone: --- → 1.1 QE2
This is also happening on 1.01.
blocking-b2g: leo+ → tef?
The input here is doing the right thing according to the spec [1]. To implement this correctly we should have an "overlay" which sits over the input which is localized to the users locale. 

http://www.w3.org/TR/html-markup/input.date.html [1]
http://tools.ietf.org/html/rfc3339#section-5
I think is pretty bad, but not a blocker, I am moving this back to leo+
blocking-b2g: tef? → leo+
(In reply to James Lal [:lightsofapollo] from comment #9)
> The input here is doing the right thing according to the spec [1]. To
> implement this correctly we should have an "overlay" which sits over the
> input which is localized to the users locale. 
> 
> http://www.w3.org/TR/html-markup/input.date.html [1]
> http://tools.ietf.org/html/rfc3339#section-5

I believe browser vendors are encouraged to display the date inside of an input type="date" according to the user's locale. Competing browsers do something like this, and we probably should as well.

That said, a simple gaia overlay as a workaround is probably going to be easier to implement :)
(In reply to Kevin Grandon :kgrandon from comment #11)
> (In reply to James Lal [:lightsofapollo] from comment #9)
> > The input here is doing the right thing according to the spec [1]. To
> > implement this correctly we should have an "overlay" which sits over the
> > input which is localized to the users locale. 
> > 
> > http://www.w3.org/TR/html-markup/input.date.html [1]
> > http://tools.ietf.org/html/rfc3339#section-5
> 
> I believe browser vendors are encouraged to display the date inside of an
> input type="date" according to the user's locale. Competing browsers do
> something like this, and we probably should as well.
> 
> That said, a simple gaia overlay as a workaround is probably going to be
> easier to implement :)

Yep, this is what I've figured out and starting working on.
(In reply to Alexandre LISSY :gerard-majax from comment #12)
> (In reply to Kevin Grandon :kgrandon from comment #11)
> > (In reply to James Lal [:lightsofapollo] from comment #9)
> > > The input here is doing the right thing according to the spec [1]. To
> > > implement this correctly we should have an "overlay" which sits over the
> > > input which is localized to the users locale. 
> > > 
> > > http://www.w3.org/TR/html-markup/input.date.html [1]
> > > http://tools.ietf.org/html/rfc3339#section-5
> > 
> > I believe browser vendors are encouraged to display the date inside of an
> > input type="date" according to the user's locale. Competing browsers do
> > something like this, and we probably should as well.
> > 
> > That said, a simple gaia overlay as a workaround is probably going to be
> > easier to implement :)
> 
> Yep, this is what I've figured out and starting working on.

I have the first bits in place, will need a bit of polish, though, but I should have a patch to propose soon.
Status: NEW → ASSIGNED
A second screenshot showing the date formatted using spanish locale.
Please find attached a screenshot showing the formatting according to locale (dateTimeFormat_%x)
Severity: normal → critical
Severity: critical → normal
Priority: -- → P1
Please find the pull request for v1-train.
Attachment #749187 - Flags: review?(kgrandon)
Please find the link for the pull request for master branch
Attachment #749189 - Flags: review?(kgrandon)
Comment on attachment 749187 [details]
Link to Github https://github.com/mozilla-b2g/gaia/pull/9750

Removing this pull request because only one against master is needed.
Attachment #749187 - Attachment is obsolete: true
Attachment #749187 - Flags: review?(kgrandon)
Attachment #749189 - Flags: review?(felash)
Please note that the tests might fail due to bug 872424
Comment on attachment 749189 [details]
Link to Github https://github.com/mozilla-b2g/gaia/pull/9751

I'll leave felash on review? in case there was something specific you wanted him to look at, otherwise this has landed on master.
Attachment #749189 - Flags: review?(kgrandon) → review+
Requesting for v1-train uplift
tracking-b2g18: --- → ?
Blocks: 872922
(In reply to Leo from comment #22)
> Requesting for v1-train uplift

You've already got leo+ here. No need to nominate for uplift - someone will come by to uplift this.
tracking-b2g18: ? → ---
Comment on attachment 749189 [details]
Link to Github https://github.com/mozilla-b2g/gaia/pull/9751

my r= was for the test part, that looks good to me.
Attachment #749189 - Flags: review?(felash) → review+
Duplicate of this bug: 797707
in master: https://github.com/mozilla-b2g/gaia/commit/bbd6e46084370f3aee54231695880bb702299710
Status: ASSIGNED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Keywords: verifyme
QA Contact: jsmith
Uplifted bbd6e46084370f3aee54231695880bb702299710 to:
v1-train: 8de87b27aea21f81bd7f4bdbdc66aebae53d0a83
Verified on b2g18 on a 5/20 build with some sanity testing with the Spanish locale.
Flags: in-moztrap?
Flags: in-moztrap? → in-moztrap+
Added Calendar Suite Test Case #8757 [Calendar] Verify the correct time format is displayed while creating Calendar events in the Spanish language
You need to log in before you can comment on or make changes to this bug.