Closed Bug 863238 Opened 8 years ago Closed 8 years ago

Not localized mozilla pages opened from the Firefox options

Categories

(www.mozilla.org :: L10N, defect)

x86
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 854644

People

(Reporter: simona.marcu, Unassigned)

Details

Mozilla/5.0 (Windows NT 5.1; rv:23.0) Gecko/20130417 Firefox/23.0

The content of some webpages that are opened from the Help menu or from warnings (the reported web forgery one) is not (entirely)localized.

Steps to reproduce:
1. Install a locale build (for e.g da)
2. Launch Firefox and navigate to:
http://mozilla.org/firefox/its-an-attack.html
3. Click on Why was this page blocked button (the right-most button)
4. Go to the Help menu and click on Firefox Help and Firefox Health Report options.

Expected results:
All the opened webpages are localized.

Actual results:
In step 3: You are redirected to a page that is entirely in English (not in da)
http://www.mozilla.org/en-US/firefox/phishing-protection/firefox2/
In step 4:
http://support.mozilla.org/da/products/firefox?as=u&utm_source=inproduct - Firefox Help page is partially localized (some of the text is written in English).
about:healthreport -Firefox Health Report- the page is entirely written in English.

Note:
Reproducible also on Firefox 21 beta 3 and on Aurora 22.0a2.
+ pascal and ibai
The first page you mentionned is not owned by Mozilla but by Google, it's translation depends on them (it is fully translated in French for example).

The sumo page is just not entirely translated in Danish, not really a bug, we just need more volunteers for that, i'll let Ibai decides if he wants a specific bug for that.

About:healthreport is being translated now, we have ~50 locales ready, Danish is just not part of them.

None of these pages are on www.mozilla.org, there is already a bug filed for about:healreport in Danish (Bug 854644), I am going to dupe that bug to this one.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 854644
(In reply to Pascal Chevrel:pascalc from comment #2)
> The first page you mentionned is not owned by Mozilla but by Google, it's
> translation depends on them (it is fully translated in French for example).
> 
> The sumo page is just not entirely translated in Danish, not really a bug,
> we just need more volunteers for that, i'll let Ibai decides if he wants a
> specific bug for that.
> 
> About:healthreport is being translated now, we have ~50 locales ready,
> Danish is just not part of them.
> 
> None of these pages are on www.mozilla.org, there is already a bug filed for
> about:healreport in Danish (Bug 854644), I am going to dupe that bug to this
> one.

Thanks for clarifying things for me...but still if I'm on a danish build and I hit a Phishing site like http://skjode.dk/royt.htm I'll get an explanation for "Why was this page blocked?" in English. I've also tried with different locales and I get the same result (es_Es and fr).
That would be the ideal situation. The reality is that some communities are really small and can't cover all the content that we have in English. 

In SUMO we are working on a plan to address this situation and we should be in a better position soon.

Thanks for reporting.
Filed Bug 863279 to cover the scenario mentioned in step 4.
You need to log in before you can comment on or make changes to this bug.