Closed Bug 863501 (music-playlist) Opened 7 years ago Closed 2 years ago

[Meta] [Music] Support user playlists

Categories

(Firefox OS Graveyard :: Gaia::Music, enhancement)

ARM
Gonk (Firefox OS)
enhancement
Not set

Tracking

(tracking-b2g:backlog)

RESOLVED WONTFIX
tracking-b2g backlog

People

(Reporter: nhirata, Assigned: errietta)

References

Details

(Whiteboard: fixinmusic2, ux-tracking)

Attachments

(3 files)

## Environment :
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/f671fa539473
Gaia   e7e338a765e22334b40ced41489a785941382c66
BuildID 20130411070205
Version 18.0
Leo
## Repro :
1. launch music app
2. long tap on a song in any of the views

## Expected :
1. a menu pops up to either share or add to playlist

## Actual :
1. bluetooth sharing appears

## Note :
1. future enhancement request for 1.x or 2.x
2. I find it odd that I can't create my own playlist; android has this option.  UI is very similar to Android...
Really really would like the ability to create a playlist.  This is annoying to me using the music app.  I have to listen to all my songs and constantly press forward if I don't want to listen to the song.
Whiteboard: uxwanted
+1 to Naoki everyone wants the ability to create and play playlist.

I got a reply in B2G dev list saying its being worked on , I wish they add support to online music streams in the music player.
This work keeps getting pushed for other priorities, but specs and design work are done and have been user tested.
(In reply to Stephany Wilkes from comment #3)
> This work keeps getting pushed for other priorities, but specs and design
> work are done and have been user tested.

Thats great news , so it would probably come in 2.2 ?
Duplicate of this bug: 1091169
Duplicate of this bug: 980644
Whiteboard: uxwanted → uxwanted, fixinmusic2
We now have a UX spec.
Alias: music-playlist
Summary: [Music] An option to should appear when long tapping on a song, one of which should be add to playlist and allowing to create a playlist → [Meta] [Music] Support user playlists
Whiteboard: uxwanted, fixinmusic2 → fixinmusic2
Depends on: 1093219
Depends on: 1093225
Depends on: 1093227
Depends on: 1093233
Depends on: 1093236
feature-b2g: --- → 2.2?
Blocks: 2.2-music
Blocks: 1098152
No longer blocks: 1098152
Depends on: 994991, 1098152
Whiteboard: fixinmusic2 → fixinmusic2, ux-most-wanted-nov2014
Blocks: 1098152, 994991
No longer depends on: 994991, 1098152
I see comments saying we have a design, but this bug has no design attached to it. Not so great if someone wanted to pick this up - can we get the design attached to this bug please?
Flags: needinfo?(rmacdonald)
Chris,

This is a feature that was planned for 2.2 before the great 2.2 cancellation of 2014 at the all-hands.

Hung,

Can get this doc in a public place? Not sure where the latest version is.
Flags: needinfo?(rmacdonald) → needinfo?(hnguyen)
Attaching the visual specification along with assets. 

If some kind soul were take the time to build this, I will forever be in their debt. :)
Flags: needinfo?(hnguyen)
Attached file Music_Playlists.pdf
Adding interaction specification as well.
Assignee: nobody → errietta
Candice / Michael, can you either + or - it? Thanks.
Flags: needinfo?(mtreese)
Flags: needinfo?(cserran)
This is not in scope for 2.2 based on new release plans. Removing from nom
feature-b2g: 2.2? → ---
Had Hema update the flag, removing NI
Flags: needinfo?(cserran)
Comment on attachment 8544110 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/27125

Errietta,

I have left the comments on the github PR. This look promising but there are several bits on functionality that don't really work as spec'd or at all.

Thank you very much for tackling this.
Attachment #8544110 - Flags: feedback?(hub) → feedback-
In the attached zip file, there's a 'visual design spec'. In page 34 of that, there is empty playlist design. Can I please have the image that's on that page, and also how is the button styled?
Flags: needinfo?(hnguyen)
Hi Errietta 

Sorry but I do not currently have the bandwidth to support this feature since its not officially in scope for the 2.2. 

Can you use a placeholder for the time being and just ensure the functionality is there? I should have some time to look at this in the following weeks. 

Thanks again for all you efforts.
Flags: needinfo?(hnguyen)
Move to backlog for consideration in 3.0
blocking-b2g: --- → backlog
Flags: needinfo?(mtreese)
blocking-b2g: backlog → ---
The attached PR is according to the contributor, functional. Now we need to figure out the plan with it as we move to NGA.
Blocks: 1123216
Whiteboard: fixinmusic2, ux-most-wanted-nov2014 → fixinmusic2, ux-tracking
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.