[Buri][SOS]NO any prompts during a call, when dial a emergency call from emergency call keypad.

RESOLVED FIXED in 1.0.1 IOT1 (10may)

Status

Firefox OS
Gaia::System
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sync-1, Assigned: Anshul)

Tracking

unspecified
1.0.1 IOT1 (10may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.1 fixed)

Details

(Whiteboard: [status: awaiting landing of r+'d bug 866481] u=fx-os-user c=may-6-17 p=1, [target:05/17])

Attachments

(9 attachments, 1 obsolete attachment)

38.37 KB, image/jpeg
Details
9.49 MB, video/mp4
Details
146.35 KB, image/png
Details
10.00 MB, application/octet-stream
Details
10.00 MB, application/octet-stream
Details
10.00 MB, application/octet-stream
Details
10.00 MB, application/octet-stream
Details
4.59 MB, application/octet-stream
Details
347.08 KB, text/plain
Details
(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.077
 Firefox os  v1.0.1
 Mozilla build ID:20130414070204
 
 +++ This bug was initially created as a clone of Bug #443235 +++
 
 DEFECT DESCRIPTION:
 [SOS]NO any prompts during a call, when dial a emergency call from emergency call keypad.
 
  REPRODUCING PROCEDURES:
 1.enable Lock screen and password lock
 2.make a call(10010) -> during the call
 3.press power key to lock screen -> wake up the screen
 4.press Home key switch the call to background -> unlock the screen -> on the password keypad press "Emergency call" -> show the emergency call keypad
 5.dial 112
 6.no any prompts and can not dial out
 
  EXPECTED BEHAVIOUR:
 Pop up some prompts that the user is already in the call.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #443235 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 739442 [details]
snapshot

Clone from brother

Comment 3

5 years ago
if multi dial out call is not support, please disable dialpad when it's already in call.
blocking-b2g: --- → tef?
Etienne, is this a dupe of a blocker from last week at workweek?
Flags: needinfo?(etienne)
(In reply to Dietrich Ayala (:dietrich) from comment #4)
> Etienne, is this a dupe of a blocker from last week at workweek?

not a dupe, arguably a follow up
Flags: needinfo?(etienne)
Could we simply disable the "Emergency Call" if there is already an ongoing call?
blocking-b2g: tef? → tef+
Flags: needinfo?(etienne)
Target Milestone: --- → 1.0.1 IOT1 (10may)
Etienne, this will probably end up with you in the end anyway.
Assignee: nobody → etienne
Created attachment 742469 [details] [diff] [review]
WIP

I'm in favor of displaying an alert when we try to launch the call from the lockscreen.

Disabling the button would involve constantly observing the calls and could really be confusing to the users.

Here is a WIP, without the l10n part.

I'd like to either fix the bug with the needed l10n add, or leave the bug unfixed.
Attachment #742469 - Flags: feedback?(francisco.jordano)
Flags: needinfo?(etienne)
Comment on attachment 742469 [details] [diff] [review]
WIP

Review of attachment 742469 [details] [diff] [review]:
-----------------------------------------------------------------

As Etienne commented, I also prefer the idea of the message, it's the safest solution and the code needed is pretty straight forward.

The WIP looking good to me.

Cheers!

::: apps/system/emergency-call/js/dialer.js
@@ +18,5 @@
> +      var ok = this._alertOK;
> +      alert.hidden = false;
> +      ok.addEvenListener('click', function close() {
> +        ok.removeEventListener('click', close);
> +        alert.hidden = false;

when we click to close the 'alert' message, that 'alert' should be hidden isn't?
Attachment #742469 - Flags: feedback?(francisco.jordano) → feedback+

Comment 10

5 years ago
Flagged Francis as needinfo to address these UX aspects of comment 8 (and advise on them or propose a different approach, etc.):

"I'm in favor of displaying an alert when we try to launch the call from the lockscreen.

Disabling the button would involve constantly observing the calls and could really be confusing to the users."
Flags: needinfo?(fdjabri)
Whiteboard: UX-P?
Keywords: late-l10n
If multi dial out is not supported, then I would argue that the correct behavior would be to allow the user to dial emergency services, but warn the user that by doing so, they will drop the existing call. 

The dialog should read (text to be confirmed): Calling '<number>' will end your current call. Continue? (Options: No/Yes)

Is this possible?
Flags: needinfo?(fdjabri)
(Assignee)

Comment 12

5 years ago
Francis, if you dial a number when there is another call modem will put the existing call on hold and resume he held call when the emergency call is disconnected. So I don't think it is good to assume that the second call will be dropped.

I will test this behavior with commercial RIL and update tomorrow.
If the existing call can be put on hold, I agree this should be the expected behavior for this bug. 
If this is not supported, then I would argue that giving the user the option to drop the existing call would be a better outcome than preventing them from calling emergency services while a call is ongoing.

Updated

5 years ago
Whiteboard: UX-P?
(Assignee)

Comment 14

5 years ago
Francis, I confirmed with commercial RIL that the existing call is put on hold and the emergency call is dialed. There was a little bug in commercial RIL that I fixed and not this scenario works with the exception of the following issues.

- If the dialed number is not an emergency number, RIL send an error messsage "RIL:CallError", "{callIndex:-1, error:'BadNumberError'}", which ends up disconnecting the existing call.
- When dialing the new emergency number, the numbers being pressed are sent as DTMF to the network, which is not correct either.

Please see the attached video of the sequence with commercial RIL.
(Assignee)

Comment 15

5 years ago
Created attachment 744219 [details]
Dial an emergency number when there is an existing call (working with commercial RIL)
Very interesting, let's see if the default behavior allows us to close this bug once  bug 866481 is fixed.
Attachment #742469 - Attachment is obsolete: true
Can you test again with the patch on bug 866481?

This patch fixes the emergency calls from the lockscreen, and it looks like the RIL does the rest and everything works fine :)
Flags: needinfo?(sync-1)
Keywords: late-l10n
(Assignee)

Comment 18

5 years ago
Etienne, the patch in bug 866481 doesn't seem to fix either of the issues mentioned in my comment #14. The UI glitch in the video turned out to be the RIL issue that I resolved.

Comment 19

5 years ago
(In reply to Etienne Segonzac (:etienne) from comment #17)
> Can you test again with the patch on bug 866481?
> 
> This patch fixes the emergency calls from the lockscreen, and it looks like
> the RIL does the rest and everything works fine :)

Dear Etienne,
I have tried your patch, it did not work.Please refer to the attachment.
Flags: needinfo?(sync-1)

Comment 20

5 years ago
Created attachment 745001 [details]
snapshot

Comment 21

5 years ago
How about solution this bug like android phone's behavior:
Change the "Emergency Call" button to "Return the call" button when
one call established on passcode lock screen.

Comment 22

5 years ago
This abnormal screen is also displayed when try to add 2nd call in contact during a call.
At the first time to swap the call(1st call: active -> hold, 2nd call : alerting -> active), it only updates 2nd call status in gecko layer.
We really need to fix the emergency call from the lockscreen before we take any decision here.
Depends on: 866481

Comment 24

5 years ago
Just checking in on the UX here: Was Francis's UX recommendation taken into account, or is this bug about something else now (per comment 23)?
(In reply to Stephany Wilkes from comment #24)
> Just checking in on the UX here: Was Francis's UX recommendation taken into
> account, or is this bug about something else now (per comment 23)?

We're hoping that the RIL will do exactly what we want (ie. the best case scenario in Francis' comment) once the basic feature is fixed.
(In reply to Etienne Segonzac (:etienne) from comment #23)
> We really need to fix the emergency call from the lockscreen before we take
> any decision here.

Hi Etienne, seem like bug 866481 is resolved (with updated information that it's mistakenly reported as patch not working ealier). What do you suggest as next step? Thanks
Flags: needinfo?(etienne)
Whiteboard: u=fx-os-user c=may-6-17 p=0
Whiteboard: u=fx-os-user c=may-6-17 p=0 → u=fx-os-user c=may-6-17 p=1
(Assignee)

Comment 27

5 years ago
The support for adding a call when in emergency mode is available in commercial RIL in AU AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.096 or later.

I would prefer that we allow user to place the call through emergency dialer when there is a call and not show the return to call option as Android does but I am okay with either of the approaches.
(In reply to Joe Cheng [:jcheng] from comment #26)
> (In reply to Etienne Segonzac (:etienne) from comment #23)
> > We really need to fix the emergency call from the lockscreen before we take
> > any decision here.
> 
> Hi Etienne, seem like bug 866481 is resolved (with updated information that
> it's mistakenly reported as patch not working ealier). What do you suggest
> as next step? Thanks

Well, it's not landed yet.

I suggest pinging the reviewer to get it reviewed/landed soon so we can move forward on this one :)
Flags: needinfo?(etienne)
Whiteboard: u=fx-os-user c=may-6-17 p=1 → [status: awaiting landing of r+'d bug 866481] u=fx-os-user c=may-6-17 p=1
Depends on: 870714
No longer depends on: 870714
So now that bug 870714 landed...if you follow the STR:

- the first call will be put on hold
- the emergency call will be dialed
- the call screen will appear

So, WORKSFORME?
Flags: needinfo?(sync-1)
Keywords: qawanted

Comment 30

5 years ago
This bug reproduces on the Buri latest build
Emergency phone call is made, but no any information displays that 911 is dialed, just a phone number from the ongoing call

Environmental  Variables:
Buri Build ID: 20130513070209
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/6e1dbf036d34
Gaia: 54dfb62735c81152eef74eb1768e2bf621c0a258
Keywords: qawanted
Whiteboard: [status: awaiting landing of r+'d bug 866481] u=fx-os-user c=may-6-17 p=1 → [status: awaiting landing of r+'d bug 866481] u=fx-os-user c=may-6-17 p=1, [target:05/17]

Comment 31

5 years ago
Created attachment 749171 [details]
video

(In reply to Etienne Segonzac (:etienne) from comment #29)
> So now that bug 870714 landed...if you follow the STR:
> 
> - the first call will be put on hold
> - the emergency call will be dialed
> - the call screen will appear
> 
> So, WORKSFORME?

Etienne, sorry, I am not quite understand your mean. So I recorded a video, please refer to the attachments.Hope it can help you.

By the way our code is based on:
AU_LINUX_GECKO_ICS_STRAWEBRRY_V1.01.00.01.019.094
Firefox os  v1.0.1
Mozilla build ID:20130502070201
Flags: needinfo?(sync-1)

Comment 32

5 years ago
Created attachment 749172 [details]
video

Comment 33

5 years ago
Created attachment 749173 [details]
video

Comment 34

5 years ago
Created attachment 749175 [details]
video

Comment 35

5 years ago
Created attachment 749176 [details]
video
> - the first call will be put on hold
> - the emergency call will be dialed
> - the call screen will appear

The video shows exactly that. And I was under the impression that this was what we wanted to do in the best case scenario (See Comment 12, Comment 13).

I'm not sure what that the blocking issue is anymore.
Mingming ZHAO, can you please describe exactly what you're expecting to see fixed here, if anything? Thanks!
Flags: needinfo?(sync-1)
(Assignee)

Comment 38

5 years ago
Mingming, let me try to summarize what I think you are saying are the issues.

1. As per your comment #30 the emergency call label is not shown. This will be fixes when the support for bug 863281 is available in commercial RIL (ETA 2 days)
2. When the previous call is on hold and the emergency call was active, clicking on the calls wasn't switching the calls. I would need Android logs as per instructions below to debug the issue.
 adb logcat -b radio -b main -v time

Comment 39

5 years ago
Dears,
Through discussions, we can accept the present case that is
> - the first call will be put on hold
> - the emergency call will be dialed
> - the call screen will appear

But why can not switch the two calls?
Flags: needinfo?(sync-1)

Comment 40

5 years ago
(In reply to Anshul from comment #38)
> Mingming, let me try to summarize what I think you are saying are the issues.
> 
> 1. As per your comment #30 the emergency call label is not shown. This will
> be fixes when the support for bug 863281 is available in commercial RIL (ETA
> 2 days)

You mean that when dial emergency call (112), it will display "Emergency call" label under the number (112)? And whether the recent call log will also display the "Emergency call" label under the Emergency number?

> 2. When the previous call is on hold and the emergency call was active,
> clicking on the calls wasn't switching the calls. I would need Android logs
> as per instructions below to debug the issue.

Please refer to the attachment "switch-calls.txt".

Comment 41

5 years ago
Created attachment 749718 [details]
switch calls
(In reply to Mingming ZHAO from comment #39)
> Dears,
> Through discussions, we can accept the present case that is
> > - the first call will be put on hold
> > - the emergency call will be dialed
> > - the call screen will appear
> 
> But why can not switch the two calls?

If this is the issue let's update the description/file a new bug.
(Assignee)

Comment 43

5 years ago
Mingming, from your logs when a dial request is made I should see a switch request, which I don't.

 405 49:01-01 01:02:32.385 D/RIL_QC_B2G(  146): [0193]< GET_CURRENT_CALLS {[id=1,ACTIVE,toa=129,norm,mo,als=0,voc,noevp,10010,cli=0,name='',0,]}

  407 49:01-01 01:02:34.755 D/RIL_QC_B2G(  146): [0194]> GET_CURRENT_CALLS

  452 49:01-01 01:02:40.595 D/RIL_QC_B2G(  146): [0213]> DIAL 112 0

  453 49:01-01 01:02:40.605 D/RIL_QC_B2G(  146): [0213]< DIAL

  454 49:01-01 01:02:40.605 D/RIL_QC_B2G(  146): [0214]> GET_CURRENT_CALLS

  456 49:01-01 01:02:40.605 D/RIL_QC_B2G(  146): [0215]> GET_CURRENT_CALLS

  457 49:01-01 01:02:40.615 D/RIL_QC_B2G(  146): [0214]< GET_CURRENT_CALLS {[id=1,DIALING,toa=129,norm,mo,als=0,voc,noevp,112,cli=0,name='',0,]}

This makes me wonder if you are using an older AU. Could you please let me know which AU you are using. I tried the exact same steps and I don't see the issue. Please provide both the main logs and the radio logs by running the following command
  adb logcat -b radio -b main -v time 

This is a different issue than the one originaly reported by this bug so I suggest if you still see the issue on the latest AU, please file a new bug.

From the videos I can see this issue is resolved so I am marking it fixed.
Assignee: etienne → anshulj
(Assignee)

Comment 44

5 years ago
Mingming, from your logs when a dial request is made I should see a switch request, which I don't.

 405 49:01-01 01:02:32.385 D/RIL_QC_B2G(  146): [0193]< GET_CURRENT_CALLS {[id=1,ACTIVE,toa=129,norm,mo,als=0,voc,noevp,10010,cli=0,name='',0,]}

  407 49:01-01 01:02:34.755 D/RIL_QC_B2G(  146): [0194]> GET_CURRENT_CALLS

  452 49:01-01 01:02:40.595 D/RIL_QC_B2G(  146): [0213]> DIAL 112 0

  453 49:01-01 01:02:40.605 D/RIL_QC_B2G(  146): [0213]< DIAL

  454 49:01-01 01:02:40.605 D/RIL_QC_B2G(  146): [0214]> GET_CURRENT_CALLS

  456 49:01-01 01:02:40.605 D/RIL_QC_B2G(  146): [0215]> GET_CURRENT_CALLS

  457 49:01-01 01:02:40.615 D/RIL_QC_B2G(  146): [0214]< GET_CURRENT_CALLS {[id=1,DIALING,toa=129,norm,mo,als=0,voc,noevp,112,cli=0,name='',0,]}

This makes me wonder if you are using an older AU. Could you please let me know which AU you are using. I tried the exact same steps and I don't see the issue. Please provide both the main logs and the radio logs by running the following command
  adb logcat -b radio -b main -v time 

This is a different issue than the one originaly reported by this bug so I suggest if you still see the issue on the latest AU, please file a new bug.

From the videos I can see this issue is resolved so I am marking it fixed.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-b2g18: --- → fixed
status-b2g18-v1.0.1: --- → fixed
You need to log in before you can comment on or make changes to this bug.