Closed Bug 870714 Opened 11 years ago Closed 10 years ago

If an emergency call started from the lockscreen triggers an error, the call screen will stay open (user needs to press the hangup button to close)

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g18+)

RESOLVED FIXED
Tracking Status
b2g18 + ---

People

(Reporter: etienne, Unassigned)

References

Details

(Whiteboard: [status: ready to land?] IOT,[mozilla-triage], QARegressExclude)

+++ This bug was initially created as a clone of Bug #866481 +++

STR:
- with no sim card in your phone
- go to a country where emergency calls are not allowed without an SIM
- enable the phone passcode
- lock the phone
- unlock the phone
- launch an emergency call from the lockscreen

Expected:
- an error prompt probably (although it would require new l10n strings)
- at least no weird call screen

Actual:
- the call screen stays open with no calls attached to it, need to press the hangup button to close it 

See: https://bugzilla.mozilla.org/attachment.cgi?id=746442
No longer blocks: 863595
Depends on: 823958
Hi, Etienne, could I get your feedback to know if this is all about Gaia work, or need other team's help? ex. RIL? Thanks. It looks like all Gaia work to me. Please correct me if I am wrong.
Flags: needinfo?(etienne)
It has a hard dependence on the platform bug 823958.
But once this one gets resolved, it's only gaia.
Flags: needinfo?(etienne)
Hi, bug 823958 is just nominated as leo?

taking into account this problem, we should nominate for tef? as well the dependency.

Cheers,
F.
Can we find out if any of our markets are impacted by step 2 of the STR?
blocking-b2g: tef+ → tef?
Flags: needinfo?(dcoloma)
Same question goes for other partners (ni on Kev/Joe)
Flags: needinfo?(kev)
Flags: needinfo?(jcheng)
Confirmed that the launch country for my partner requires that emergency calls go through without a SIM, so this is a non-blocker for them.
Flags: needinfo?(kev)
clear ni? flag on my as it's covered by comment 6
Flags: needinfo?(jcheng)
Not a blocker for partners we've talked to thus far. Sent email to dcoloma asking for a renom if this is a blocker from his perspective.
blocking-b2g: tef? → -
Actually, this may be leo+
blocking-b2g: - → leo?
Infact this issue still happen on my phone in Xi'an China, but my colleague said it is ok in ShangHai.
We discussed this in triage and everyone felt it to be a corner case and not a blocker , if partner thinks this may be a blocker in there countries please renominate.
blocking-b2g: leo? → -
Whiteboard: [status: ready to land?] IOT u=fx-os-user c=may-6-17 p=1 → [status: ready to land?] IOT
Even if it is a corner case, we need to be extremely cautious with the device behaviour when trying to make an Emergency Call. This does not affect TEF 1.0.1 markets but 1.1 ones. I'd suggest we reconsider the decision, I think we are still in time to fix this for 1.1. Furthermore, the platform bug it depends on (bug 823958) is landing now. 

I'd like also to know the opinion from our leo partners
blocking-b2g: - → leo?
Flags: needinfo?(dcoloma) → needinfo?(leo.bugzilla.gaia)
Whiteboard: [status: ready to land?] IOT → [status: ready to land?] IOT,[mozilla-triage]
It's not blocker for leo, but need to be fixed for future extention.  leo -, tracking +
blocking-b2g: leo? → ---
tracking-b2g18: --- → +
Flags: needinfo?(leo.bugzilla.gaia)
So this shouldn't happen anymore on a gecko with bug 823958 landed.
Feel free to close if it's not reproducible anymore.
Keywords: qawanted
Unable to test due to all device here because all devices here have to have the ability to call emergency number without a sim.
Whiteboard: [status: ready to land?] IOT,[mozilla-triage] → [status: ready to land?] IOT,[mozilla-triage], QARegressExclude
(In reply to Etienne Segonzac (:etienne) from comment #14)
> So this shouldn't happen anymore on a gecko with bug 823958 landed.
> Feel free to close if it's not reproducible anymore.

Since we have a hard time testing on our side, I'm going to close this out based on your assessment.
Status: NEW → RESOLVED
Closed: 10 years ago
Keywords: qawanted
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.